Repeated crashes on 1.3.113 on Mac and Ubuntu

I’ve downloaded the mac test build and installed - it seems to be improved (I visited google, facebook and reddit without a crash) but it crashed after those sites, and still does not let me open the Sync setting page without a crash.

@adamrust are you on Mojave or Catalina?

image

Hey @adamrust (and anyone else encountering this), can you open brave://crashes and send the first few reports? (Just click “Send Now”). If you could copy/paste the crash report numbers as well that’d be awesome.

There will be a free t-shirt in this for you, I swear :face_with_monocle:

PSST: make sure Automatically send crash reports to Brave is enabled in the Settings screen as well. :slight_smile:

The trouble there is that going to that page also crashes Brave… I noticed the page rendered for a fraction of a second before crashing, so I took a screen recording and scrubbed through it to see what loaded, screenshot posted below. Unfortunately, I’m not currently able to load the settings page to turn on automatic reporting, but I’ll continue to attempt that because the settings were loading for me before.

Ok, another shocking update. I was able to get automatic reporting turned on, and after the required relaunch to enable it, the crashes are… gone? I haven’t had one crash since then. I’ll update again if things change, but for now, the problem has disappeared.

I was able to upload a couple of the crash reports from when the issue happened, I’ll post them below. Let me know if you’d like more, there’s a lot.

f012ebc2fad17ecd

ff30796c479b7269

e2ddefe8e8c2c1c0

47ed432a52b52666

9e4e29f9b4baea3a

Same problem… None of the binary’s that you shared work as a fix work. The nightly build still works though.

I can get brave to run without crashing using:

sudo /Applications/Brave\ Browser.app/Contents/MacOS/Brave\ Browser

bob@acme ~ % sw_vers                
ProductName:	Mac OS X
ProductVersion:	10.15.3
BuildVersion:	19D76

OP here: I’m on Catalina 10.15.3 and Ubuntu 19.10. Installed the update on both and it’s crashing still. Crash reports:

mac:
26019976bafa4eb4    
16702b826c3d85d2

linux: 
b33547164d170225

If I turn off sync, the crashes stop both places.

@aphoid @srp,
We have a newer test build (v1.3.115) for users to install that should stop the crashes – can you try and install this new build and see if the crashes stop?

I’m assuming that my Brave stopped crashing because my sync eventually disabled from when I removed it from my sync chain via my phone. I can re-enable sync and test this evening if it’s still helpful.

I installed 1.3.115 on my mac and I can’t re-enable sync to check if it fixed anything.

I check my Linux box next

Before installing on my Linux box, I re-enabled syncing, but I’m seeing the same thing when I try to visit brave://sync

Also, if I change a bookmark on my iPhone or on the linux box, it doesn’t seem to be reflected on the other (I’m assuming that my Mac bookmarks aren’t syncing.

@aphoid we temporarily disabled Sync on desktop due to crashes and stability issues we were experiencing so the above is unfortunately the expected behaviour for the time being. We’ll need more time to look into what’s causing all these problems. In the meantime, sync was disabled so we can update our users to 1.3.x which includes several important fixes including a Chromium 80 bump.

@aphoid with sync disabled, has the crashes stopped for you?

I haven’t seen crashes after manually disabling my sync on 1.3.113. I had no crashes on 1.3.114 with sync disabled. I haven’t seen a crash on 1.3.115.

2 Likes

Thanks @aphoid, really appreciate the feedback!

Thanks! That seems to have done the trick.

1 Like

I appreciate that the crashes aren’t happening, but what I want out of Brave is more syncing of more things not no syncing at all. I realize that the devs are working on it. I hope they fix it soon.

-a

Just updated to 1.3.118. I’m still seeing “This site can’t be reached” when I go to brave://sync, and it talks about “chrome://sync/” in the tab title and the page.

Any progress on re-enabling sync?

Also, “Sync” is missing from the brave://settings sidebar on macOS. it’s there in the sidebar on linux, but there’s nothing between the Appearance and Shields sections.

@aphoid,
Thanks for updating us. We’re still working out the kinks in Sync right now, but have made significant progress in resolving them. We don’t, however, want to claim that Sync is “fixed” before it actually is.
We do appreciate everyone’s patience.