Crashing consistently and unpredictably on MacOS

I have Brave installed on many machines and I’m using Sync across a lot of them. Lately Brave has been crashing on the laptop that I use most often, running macos 10.14.

I don’t know how to reproduce the issue. It crashes some time after using it, never at startup but usually within 10 minutes. I found another post on this forum (Brave release constantly crashing on Mac OSX 10.14 - Macbook Pro 13" 2016) suggesting looking for a folder called BraveSoftware at Users/YourUserName/Library/"Application Support"/, I have no folder called Application Support in that location, although there is one at /Library/. There is no folder inside that location called BraveSoftware. I’ve also searched the hard drive for that folder and found nothing. The only thing called Brave on the laptop is the application itself.

I tried to attach the error report to the bottom of this message but it won’t let me post something that long. I would truncate it but I have no idea what the important parts of it are.

Version 0.68.140 Chromium: 77.0.3865.90 (Official Build) (64-bit)

Thanks in advance!

C

same problem here, if not worse.

starting yesterday brave would crash completely within 2 minutes of every start. ended up deleting all of its data, which resolved the crashes following an update, however hasn’t solved the issue, because now it just freezes up every few seconds. i either get no response at all or the spinning rainbow on mac, followed by cleanmymac notifications that it froze up. this lasts for 10-20 seconds and is complimented by stuttering and general slowness which makes using the browser impossible. i even upgraded my whole mac to the catalina beta as a final resort (+ 2 brave resintalls) cuz i rely on brave THAT much, but same problem. good to know its not only my machine at least. (since i didnt reset, just upgraded. too much of a headache to reset now when i was going to for the official catalina release)

Version 0.68.140 Chromium: 77.0.3865.90 (Official Build) (64-bit)
macbook pro 13 inch 2016 - mojave latest & catalina beta 10.15

sent from firefox :confused:

edit: okay reinstalled completely again, this time running it completely vanilla with no sync chain and no bookmarks imported. 10 minutes and no freezing. seems sync chain is the issue. will keep trying and then importing bookmarks manually

edit 2: okay, just about 2 hours now without any freezing or crashes, even after i manually put my bookmarks and extensions back in. issue is definitely with sync chain. simply removing it doesn’t suffice, you need a clean uninstall too.

1 Like

Thanks for this. Interesting though, I have the sync chain enabled on many machines (I like to tinker). Some with Windows and some with macos, and as of now there’s only one machine giving me trouble.

I think I’ll turn the sync off on the offending machine and see if it helps. It’s a shame because Sync is really one of the best features of Brave and the one I would hate most to lose.

yeah i do need it back eventually lol, hope they can fix it until then. no problems on my linux machine with sync chain on either. don’t forget to export your bookmarks and do a clean re-install, including deleting the brave folder in library - application support. i’ve had no issues for hours.

This topic was automatically closed after 30 days. New replies are no longer allowed.