Reddit broken / (vote button not working, image expand not working, error loading JS chunk)

Description of the issue
I’ve used Brave as my daily browser for about 1.5years now. I use Reddit a lot. Recently, Reddit seems broke while using Brave. I first noticed when the up/down vote links no longer worked. Then I noticed the image expander (+) icon was broken (used to expand an image thumbnail). Then I noticed pretty much every link driven by JavaScript was broken on the page.

I tried turning shields off but it did not fix the problem.

I tried logging out and back in, but it did not fix the problem.

I logged in using Chrome and the site works as expected.

In the JS console, I see it failed to load one of the JS chunks (repeated reloads repeat this behavior/error).

It could be there’s something funky with my account, but the fact that it works with Chrome leads me to believe that it is not.

Exact URL of the website in question

http://reddit.com

Did the issue present with default Shields settings? [Default states are: Block: Ads/Trackers, 3rd Party Cookies, 3rd Party Fingerprinting Allow: Encrypt Connections enabled (HTTPS), Scripts] (yes/no)

First thing I tried was to turn shields off and reload. It did not fix the problem.

Does the site function as expected when Shields are turned off? (yes/no)

No.

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no)

No.

Does the site function as expected when using Chrome? (yes/no)

Yes, I logged into Reddit with Chrome and it works as expected.

What Brave version/Build are you using when you encounter the issue?(About Brave info)

The first thing I would do would be to update to the latest release.
You are currently using the Muon Brave build (v0.25.2). We have since deprecated Brave Muon in favor of this:


https://brave.com/download

I highly recommend you install the new build and enjoy a much better browsing experience.
It runs in parallel with the Muon version you have installed now, so you don’t have to uninstall or overwrite anything and you can even import data from your previous Brave install into the new build.

If you decide you’d like to stick with the version you’re using now and want to resolve the problem, let me know and we can continue further troubleshooting for the Muon build.

Hope this helps. Please let me know if you have any additional questions.

Woa, now I’m confused what is the difference between Brave and Brave Browser? I did a Check for updates and it said I have the latest, so I followed your link, and now installed the Brave Browser and I have both it seems now. The newer one is not having the issue with Reddit, but I’ve also got a fresh install that has no stored passwords, history, nor my BAT tokens.

Is there an easy way to migrate that user data over to the newer browser, and why are there two releases with a subtle name diff?

This should get the job done:

This topic was automatically closed after 30 days. New replies are no longer allowed.