Javascript not working?

Within the past week or 2, it seems like Brave has stopped using Javascript properly when I go to certain websites. Pictures won’t load, features won’t be active, etc. I didn’t update my computer or browser, so I’m not sure what happened. I’ve reinstalled Brave, turned shields off, made sure Javascript is enabled, and even tried adding sites to the Allow Javascript area.

Here is one of the sites I am having this issue with: https://mods.vintagestory.at/

The issue persists whether shields are on or off.

The site works fine in Chrome Version 91.0.4472.101.

I am on Brave Version 1.26.74

the site you linked works for me.
did you have tried in private mode?
if it works maybe it’s an issue with an extension.

1 Like

That’s bizarre! It does work in private mode. Why would that be the case?

Hey @TAA ! Welcome to the community :smiley:

Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

Porridge

Thanks for the greetings!

Unfortunately, that didn’t do anything, even after I relaunched Brave.

1 Like

Apologies @TAA , I misread your previous reply to @tortino .

If everything works in private mode, then the issue is most definitely related to an extension you have installed.

Can you try disabling extensions?

Porridge

Ugh, looks like it was NoScript. I love that extension! I haven’t updated it recently, so I’m not sure why it stopped working… any ways I can use NoScript or something similar?

1 Like

I am not too familiar with NoScript, but isn’t it’s purpose to block scripts ( including javascript ) from running in your browser?

You can already do this without that extension in Brave; when you visit a site that you do not want to have javascript run inm you can click the padlock icon in the address bar and click on Site settings.

This takes you to a new page where you can toggle Javascript to be allowed or not.

Hope this helped!

Porridge

3 Likes

Does that include other scripts as well? I use NoScript so nothing gets through unless I want to to.

Hah, I figured it out! By opening NoScript and using custom settings, I was able to check ‘Unrestricted CSS’, and everything seems to be working now.
image
I still have no idea why it started doing this, but I’m glad it’s not Brave’s fault!

1 Like