Desktop notifications not working (ads notifications working fine though)


Description of the issue:
As title says, I’m not getting push notifications from ANY site, even when I click on “allow notifications”.

  1. Go to any page (like twitter.com for example)

  2. Wait until you get the “allow notifications?” popup and click on allow

  3. Brave will NEVER send notifications, despite having them enabled on my OS settings, some sites will even say “push notifications not supported/Your browser has notifications off or blocked for this site”.
    But those sites send me notifications when I use Chrome.

Expected result:
Receiving push notifications like other browsers do.

Brave Version( check About Brave):
v1.45.118

Additional Information:
I’m using Windows 8. And disabling shields/enabling all cookies doesn’t work. Ads push notifs work as intended.

This page works and send me push notifs but that’s it, just that page.

Are you selecting forever ?
I get the notifications like I am supposed to…

yeah everytime I click on “Forever” but it just doesn’t work.
I have no problem with Chrome and Mozilla so I don’t really know what to do.

Is there anyone I can report this directly? This is getting a little bit annoying.

Yes, open a support ticket using the link below

2 Likes

thank you, hopefully someone can help me :pray:

It’s like that by design.
Every site, which uses GPMS (Google Push Messaging Services) for it’s notifications, is somehow getting filtered by Brave: Twitter, YouTube, Odysee, and many others. So nothing is going to be “pushed” initially unless you open the page itself manually at least once .
You may set the browser to start with your OS, and let’s say Twitter to load in the active tab, and then it will work, but the inactive tabs won’t.
Which, of course, makes the whole thing useless.

So forget about this:

Not going to happen. Don’t bother with tickets.

1 Like

well that sucks I guess

Might sound weird, but could you try in a new profile / private window?

1 Like

Didn’t work but thank you for your trying to help :grimacing:

@Mattches @steeven could you please look into this.

1 Like

I will keep bumping this I get more answers :face_with_raised_eyebrow:

If push notifications are working in Chrome and other browsers they should be working in Brave. I do not see this issue on Windows or macOS so there is a good chance it’s something specific to your browser profile causing the issue.

Can you please tell me if you have any extensions installed at this time and which ones (if you’re willing)? If so, I would recommend disabling them and testing to see if one of them were the cause of the issue. You might even go further and try testing this in a new, fresh browser profile (to ensure there is no data of any kind that could cause this conflict) and see if you get the same behavior.

1 Like

Stay focused is the only extension I have installed.

Even after disabling it I’m still not getting any push notif, and obviously making a new profile doesn’t work either :frowning_face:

So stay focused will almost certainly block push notifications from appearing. When you created the new profile, did you still have you other profile window open? If so, you’ll need to test this again with only the one (new) profile open.

Can you also please go to (on your Windows system) Notifications and Actions and ensure that Brave is listed here (and also enabled)?

1 Like

Nope, I recently installed Stay focused, and I have been having this problem since September (When I started using Brave).

Weirdly enough, Brave isn’t listed there if I set it as my default browser, unlike Chrome which it is listed If i set it as default browser.
So I guess something went wrong during installation.

That usually happens when you don’t have a shortcut in Start menu. Reinstall and don’t delete said shortcut.

1 Like

Is that the only solution? Because I’d love to reinstall but I don’t want to lose my bat :frowning:

@druz,
You will have the option when uninstalling to delete user data or not — do not delete your user data when you see the option and instead just un/reinstall. When you reinstall you should have all your data in it as you did before.

1 Like

Yikes, after reinstall Brave is now listed and enabled on “notifications and actions” (win 8) but notifs still doesn’t work :grimacing: