PSA: Friendly Reminder For People Having Issues with Rewards/Ads

This doesn’t resolve anything for me. Still don’t get any ads or rewards.

How do I resolve this? I was using the same Brave wallet on all of my PCs by cloning the wallet key. However I’d been using Brave like that for over a year and it was working fine on all systems until I verified with Gemini. I was using the same key on computers at work too.

According to their guides, cloning the Wallet key is no good. Doing so likely will get your account flagged and unable to earn anything. You resolve that by messaging Mattches, Steeven, or SaltyBanana with the information mentioned in #5 above.

  • Copy/paste your Wallet ID (found on brave://rewards-internals )
  • Your OS and Brave version (first three lines in brave://version )
  • A screenshot of your Rewards panel in Settings --> Brave Rewards .

I’d been using them cloned like that since April of 2020 and up till November 2021 all PC’s received ads and rewards. I did receive all of the BAT accrued between then and November 2021 however but don’t get any ads or rewards anymore. I messaged Steeven.

Seems odd it would work fine like that for almost 2 years then all of a sudden get flagged. How was anyone supposed to know? lol

So then just have to create a new wallet on each system and link them all to the same 3rd party wallet provider account?

The whole reason I had all PC’s set up to share the same wallet seed was due to thinking I’d get flagged for using multiple wallets and sending payments to one 3rd party wallet provider. I figured they’d want everyone using the same wallet seed across systems. LOL

So I guess resolution is to just create new wallets? lol

I suspect more users are sharing the same seed / wallet between systems than are not. Just like they do with all other types of wallets.

If with ‘cloning wallet ID’ you mean copying appdata/Local/BraveSoftware/Brave-Browser from another install then that’s most likely my issue for not getting any rewards even if homepage ads are showing.

I copied that folder from Nightly over to a new Release install. Rewards were working fine on Nightly but wanted to try Release again and bring my extremely humble earnings along with me as well.

Thank you so much for all your contributions @Saoiray they really help a lot clarifying things - including this post ofc, this should be stickied!

@Drakkos yeah, it’s meant in two ways. Not sure if you followed the links to read official but here’s two different variations of what I was saying that’s on the official help guides.

1 Like

Not sure I read that exact documentation but I had the notion something like that could happen. Actually asked about it before doing it and tried not to have both browsers open at the same time (this happened always within the same computer), even renaming the old folder so it wouldn’t be there with the original name.

Guess it wasn’t enough. If being flagged was the reason for not getting rewarded then it’s good news I guess :slight_smile:

Should I reset the wallet on systems that weren’t where the original wallet was created initially?

This was the method I used. I noticed today that on the original laptop that the wallet was initially created on, I see I have pending rewards, but I haven’t used that in a long time and just noticed it today.

It seems silly though to have a restore profile function if they aren’t intended to be restored on new or multiple systems as what other reason would you even use it?

I reset Brave rewards on the non original systems with new wallets. I’ll see if they start working again. Thanks

EDIT: Rewards are working again. Still can’t verify the new wallet though. Get error at Gemini.

Ever since i migrated to a new SSD, I’m no longer getting any Notification Ads, just the wallapepr ads when i open a New Tab. Before the migration, i was getting over 5 Notification Ads per HOUR and earning good amount of BATs.

In a few days its gonna be 1 month since i migrated and I’m yet to see a single AD. My wallet is at 0.000 BAT. No earnings, no Ads seen in last 30 days it says.

I talked to a Support Staff on here via Private Messages, he recommended me to Reset the wallet and so i did. Unfortunately that did not help.

I believe something must be wrong either with my Wallet or with my Browser. I tried reinstalling but keeping the Browsing Data - it did not help.

I’m really not sure what else i can do about it.

@higangs Well, I see that Mattches is looking to see if it’s anything server side. If you haven’t heard from him yet, I’m assuming he’ll be getting back to you relatively soon. Sadly they have a lot of messages and comments to sort through daily.

We could guess at a lot of the things in the meanwhile, but it’s important to wait and make sure you’re not just flagged or something. If he can resolve things on the server side, then you’ll be fine to continue as is. But if he sees no issues, then we’ll have to troubleshoot settings on your end.

As for troubleshooting, a lot of that was talked about in the original post here in regards to making sure things like Focus Assist is off, nothing is blocking ads from appearing on your device, etc.

Don’t give a sob story about having no staff. Are you too broke to hire more people and actually appear professional?

@Ninako I’m a user, not a staff member. And when I posted on this and explained, I’m making sure people are aware. I also pursued afterwards to talk to higher management and pleaded with them to expand support here. They are in the process of hiring now, but not sure how many or when.

But main issue here is that people need to know they won’t always get quick responses. Sadly a lot of assumptions get made and people have gotten upset if their post goes more than a few hours unanswered…especially if more than a day. But it’s just a sad fact that currently it’s just how things are here.


@Saoiray Sad you even have to explain yourself. Anyone who frequents here can easily see your generous contribution to this community, @Saoiray. You are doing God’s work! Honorary Brave employee in my eyes.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.