Problems processing bank payments with latest version?

I have two Macs both running the latest Catalina and have pretty much the same extension set. I usually use one to make regular purchases from a particular site ( but today, the payment would not process. I tried maybe ten or a dozen times. Because of its urgency, I tried my other Mac and before doing so noticed that Brave on that Mac had an update notification. On the second Mac without the update, the payment went through first time. I tried making a purchase on the first Mac but it still didn’t work which makes me wonder if there is an issue with the latest update and reluctant to update Brave on my other Mac.

I’m just curious if anybody else has had any issues before I update.

[edit 01] Just to add that I tried using Chrome on the Mac with the Brave payment problem and it worked fine. I also deleted all cookies on that Mac relating to the website and my bank but I still can’t make a payment using Brave so I don’t know what else I can eliminate.

[edit 02] Even though the extension set is the same on both Macs, I disabled all extensions but it made no difference.

1 Like

Hello @okulo

could you try while the shield off?
if it work then you can report it as broken site and the team will check that

hope that help and have a nice day :slight_smile:

1 Like

I should have said that I don’t have shields up for that site anyway but as it wasn’t part of my elimination process, I forgot to mention it.

1 Like

Disabled finger printing

1 Like

did you get certain error or it just does not process it

I disabled fingerprinting but it didn’t help. I also just flushed the DNS cache - not that I expected it to work but I’m just trying everything.

I should point out that the page reports that the transaction has been made but usually, after the transaction, it shows a disc-like progress wheel for a moment then refreshes to the site’s home page but it just stalls as can be seen from the screenshot.

However, the transaction has not been made because a) when I click to check my trolley, it still has the link to 'continue to checkout and b) I don’t get the usual confirmation e-mail.

I suppose that it is just as likely to be a problem involving or any other site which is involved in processing the transaction so maybe reporting the site broken could be a bit presumptive.

As I said, everything works fine with Brave on my other Mac which is v 1.21.74 Chromium 89.0.4389.72 - the one which isn’t working is v 1.23.71 Chromium: 90.0.4430.72.

let me ask @fanboynz from the team to check this and have a nice day all of you :slight_smile:

1 Like

I don’t have a login for the bank, can the issue be replicated by just using morrisons?

Can you test in Brave Beta, does it do the same thing @okulo ?

I realised the problem of replicating this when I posted it - having to have all the bits in place that I have to use and it cannot occur without placing an order (which has to be over £40!) and then going through a payment process so I suppose that unless you have a Morrisons customer in your team, it is a bit hit and miss.

I haven’t tried Brave Beta but I will and get back as soon as I have done so.

By the way, having seen advice on a similar issue, I tried a private window but that didn’t make any difference.

I just installed and tried Brave Beta and the problem persists.

Having used Macs for three decades, I’m embarrassed that I didn’t try the first thing which I would normally do, delete the preferences file but I just tried that too and it hasn’t made any difference. However, I was curious to note that when I restarted Brave, a new preference file (~/Library/Preferences/com.brave.Browser.plist) was not created so maybe there is another file which could be tried.

I just tried deleting the preferences and the BraveSoftware folder in Applications support before relaunching Brave, effectively a fresh install, I think - no history, bookmarks, extensions, cache or anything. The problem persists.

I then restored the preferences and folders and copied the old version of Brave from my other Mac and tried again, this time successfully (see screenshot).

I think that eliminates everything but the application itself. I’ll download the app again just to see if it just my local installation.

1 Like

Fresh installation failed.

At least I have the older version which works now installed on my main Mac but I don’t know what else I can do to provide more evidence but if you need me to try anything, I’d be happy to do so.

at a guess, maybe a cookie issue? Allowing all cookies globally in brave://settings, does that help?

I have all cookies allowed and I already deleted all cookies pertaining to the shop and bank and I can see from a cookie utility that new ones were created. That said, I have successfully placed an order using v 1.21.74 Chromium: 89.0.4389.72 on the Mac which had the problems so unless there is a cookie which is not used by both versions of Brave, I don’t see how it is possible.

As I think I have shown in my process, I think I have eliminated everything but the app itself.

I’ve tried removing extensions, preferences, application support folder and cookies using the latest version of Brave and that did not make any difference; I could not place an order. I reinstalled a fresh download of the latest version. The same.

Then, having restored all the original extensions, preferences, application support folder and allowed cookies (i.e. everything but the app back as it was), I installed the older version of Brave and it worked fine; I placed the order.

I have double-checked the above process and in my amateur opinion, everything points to something in the application itself.

Is there some way to stop Brave from updating (I can’t find one) because every time I relaunch it, it updates itself and thus the problem returns and I have to manually reinstall the old version again?

I have had similar problems with Wise international transfer site the tracking of the transfer page would not load. Brave has been consistently unable to save a statement for an overseas bank transaction. I have swapped to a different browser for now but this has only been an issue in the last updated version.
In addition Enpass Password Manager extension has ceased to auto fill my user name and password as before.

Well, this is awkward. Unlike just about every other application on my Mac (I can’t think of another exception off the top of my head), I cannot configure how Brave updates itself so I have had to resort to editing my hosts file to block it - I’m just glad that I have Gas Mask to make that simpler.

But absent any progress with this issue, I am unlikely to manually update to a newer version so I am pretty much in limbo with Brave.

Try updating to the new build released today Release Channel 1.23.73

I tried it - it doesn’t work.

Does Shields affect it? Ads and trackers?