Problem downloding and uploading files 🚩

Is very annoying. All the time I have the same problem. I have to restart Brave in order to work again. But when I’m doing a task fast and I have to download or upload files it always freezes or something prohibits it from doing it.

It has been like this for more than a year now! Solve this ASAP please otherwise is impossible to continue using Brave. :triangular_flag_on_post: :triangular_flag_on_post: :triangular_flag_on_post:

Screenshot 2022-11-11 at 13.36.16

Could you try the same in a private window?
That’ll help us narrow down possible causes.

I just tried it in a private window and it didn’t work either.

Do you have Firewalls or anything?

No, I do not have any…

You could start by telling us more about what the above means, as well as what version of Brave and macOS you’re on.

1 Like

something prohibits it

The download files don’t appear on the download tab at all; they just get blocked. I only see the icon with the number of files I tried to download, as shown in the picture in the description.

The same goes for uploading files. It doesn’t let me do it on any site.

I have 2 macOS v12.6 and have been having the same problem with both for more than a year now. I usually don’t write in communities, but this is very annoying, and in general, I like Brave.

Brave Version 1.45.118

OK. Brave 1.45.123 is out now, so I would recommend upgrading regardless before going further – but since this has been ongoing I doubt it will solve anything.

I know you said you don’t have any “firewalls” involved, but do you have any other ‘security’ or ‘privacy’ software on your system?

To me this looks like there is some other software involved here.

Meanwhile, do you have this setting enabled?


If not, what is the behavior like if you enable it and try again?

Is this with various file types, or only a specific file type (such as PDF for example)?

Also, does any of these help?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.