Downloads not working, shows # in mac OS dock icon but file is nonexistent

Description of the issue:
How can this issue be reproduced?

  1. choosing any file to be downloaded, for example, thingiverse website files.
  2. download an attachment from gmail

Expected result:
file shows up in downloads as usual, which does not happen, but # gets added to dock icon

**Brave Version( check About Brave):
Version 1.32.113 Chromium: 96.0.4664.45 (Official Build) (arm64)

Additional Information:

Thank you for reaching out.
So you’re saying that the files you’re trying to download are never actually downloaded?

Additionally, can you elaborate on what you mean by ?

I’m getting the same thing on macOS using Version 1.32.113 Chromium: 96.0.4664.45 (Official Build) (x86_64).
You choose to download, nothing shows that it downloaded, but in the dock the number of downloads appear. And sometimes you can see the blue outline showing the progress, but no downloaded items appear anywhere. I don’t even get the prompt for the “Ask where to save” even with it checked.

Not hijacking original post, just wanted to add that they aren’t the only one.

Can you try testing the behavior in a new browser profile and see if you get the same results?

Yes I got the same results. It just added the number. I’ve also completely deleted Brave, including deleting the BraveSoftware folder from the Library. Same results.

can you tell me what version of macOS you’re using at this time?

I was using BigSur, but I recently updated to Monterey verson 12.0.1. I’ve had this issue for a few days, but I think it started when I updated to Monterey. I might be wrong though.

If you go to brave://settings/downloads, is the Location set to the default download location, or has this location been changed?

Tried it with the default download location and also tried it with the location change. Still same issue. I also checked and unchecked the “ask where” and it didn’t matter.

1 Like

Thank you for the information. Reaching out to the team to see if anyone has an idea on why this may be happening.

Thanks for your patience.

@Mattches No thank you! I appreciate your kindness. Be safe!

This does not happen with me on macOS 12.0.1.

It may be because I’m on the M1 (arm64) [
Version 1.32.113 Chromium: 96.0.4664.45 (Official Build) (arm64)] version.

I have the same issue on a mac, latest version. i also cannot export bookmarks. Nothing happens when i click “export bookmarks” in the book mark settings. Maybe it’s connected and there are other things not working since the last mac or brave update…

I am on an M1Pro, 2021 MBP, if that matters.

Mac OS Monterey version 12.0.1 (21A559)

The # in the dock icon changes with each download attempt.

Just noticed that in download settings, unchecking “Ask where to save each file before downloading” will now cause the downloads to complete and show up, however, the notification of # of downloads in the dock icon cannot be cleared no matter what is cleared in the downloads history, so the issue may be related.

After completing a download and going back to settings, “Ask where to save each file before downloading” seems to have reverted back to On, even after I turned it off…so its definitely related to that option as well (in my case).

1 Like

Can anyone here open another browser and test to see if downloads work normally in the other browser please?

works fine in google chrome

Works fine for me in Chrome as well. Unchecking that box doesn’t allow it to complete for me.

@Mattches Ok, so it now it is allowing me to download things, but “Save Image As” still isn’t working. I didn’t do anything for it to change.

@NoobRiot thank you for the update. We’re digging into this issue but there doesn’t appear to be any obvious cause here. Appreciate everyone’s patience as well as updates on the issue. I will reply here as soon as I have any more info.