Problem about fan running so fast?

Problem is this. I installed brave and fan running crazy. I closed many features such as rewards vpn etc. nothing happening. However when i disabled hardware acceleration its going normal when i enabled hardware acceleration fan running so fast and never stops until i closed the brave. Is there any solution about that? Also can someone give me little information about " hardware acceleration". Is this feature necessary?

– Im sorry i opened the topic wrong section if someone move thank you –

Most things on your computer uses your CPU in order to process. With computers over time being built with better dedicated graphics cards, many things started allowing access to it in order to ease the burden on your CPU and instead be shared with the GPU (graphics processing unit)

That is what hardware acceleration does. It uses your GPU to process things instead of your CPU. Generally this helps things run smoother, but only if you have a good CPU and you’re keeping all of your drivers and everything else up to date.

Obviously the more things you have running on your GPU, including active tabs or whatever in your browser, the more work it’ll have. The fans will kick on because their job is to keep the GPU and other components cool. If they get too hot, they can get damaged.

If it’s constantly running or you’re hearing it run hard, then it suggests you may need to do some regular maintenance. This could be as simple as updating your drivers on the device or changing settings for your graphics card. Beyond that though, it might just be showing signs that you need to clean the interior of your PC because of dust and all that has accumulated and now is blocking airflow, could be you need to reapply some thermal paste, or could be a sign that you need a new heat sink.

Hardware acceleration is not necessary. It just should help to reduce the burden on your PC and would help things to run smoother overall, at least in theory. How useful it is will be dependent on the build of your device.

You can read articles with more details and opinions at or

1 Like

Someone posted a solution about my problem and it is working for me.

" I found a working solution to this…
Turns out, there are two different control panels that will pick what GPU to use:

  • NVidia Control Panel
  • Windows Graphics Settings

To select integrated GPU for Brave:

  • Run “Settings”
  • Type in “Graphics Settings”
  • There will be an application list, click Browse…
  • Select Brave’s EXE file (usually “C:\Program Files\BraveSoftware\Brave-Browser\Application\brave.exe”)
  • Click on the entry
  • Click Options button
  • Select “Power Saving” (for the integrated GPU), click Save

Now Brave will use the correct GPU. "
credit by @Dwedit thank you my friend.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.