Brave causes my Core i3 laptop to spin up the cooling fan

Whenever I load Brave browser on my Core i3 laptop, the fan immediately starts spinning noticeably.

I switch to Microsoft Edge and that never happens.

@MartyKinn ,

Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

Hi

Maybe your hardware acceleration is enabled at brave://settings/system

Hardware acceleration was enabled. I disabled it and will see how it does. Thanks to all that replied with help.

Didn’t help. Fan still spins up with HA disabled