Private Tabs with Tor is always disconnected

Hello Brave Community,

When I open a private tab with Tor, it always shows the Tor status as “disconnected”. What can I do to resolve this issue?

Thanks,
FGFan420.

You might be running into this problem:

In Brave 1.26, you will be able to recover from that bad state by turning off private windows with Tor and turning back on again. At the moment, the only fix is to manually delete the tor data directory within your browser profile.

1 Like

Hi @fmarier,

Do you mean that by deleting the “tor data directory” TOR windows will again function normally in the current Release v.?

And if so, does that have to be done every time a new TOR window is opened?

Also, what are the steps to take to “delete the tor data directory within your browser profile”?

One last question: By “1.26” are you referring to Release v. 1.26?… (I’m now using the Beta [tho not the latest update] because the ‘TOR not working’ issue doesn’t occur there.)

Thanks.

Yes, if you delete the tor data directory, it should start working again in any version of Brave. 1.26 will bring a safe and easy way to perform that deletion. We don’t really recommend that users delete random files from their Brave profiles due to the risk of making a mistake (e.g. a typo).

No. It’s only necessary when the Tor daemon gets into a bad state and stops responding.

On my Linux machine, running Brave Beta, that means removing these directories:

~/.config/BraveSoftware/Brave-Browser-Beta/tor/data/
~/.config/BraveSoftware/Brave-Browser-Beta/tor/watch/

That means Brave 1.26, regardless of the channel you are on. The feature landed on the 1.26 branch and so it’s currently included in the Beta (1.26) and Nightly (1.27) channels. The 1.26 branch will migrate to the release channel next month.

1 Like

@fmarier Sorry, was AWOL for a few weeks. Thanks for all that.

@fmarier or anyone, would you know how to do this on a Win 10 machine?

Thanks!

-------- EDIT-------

Found this which seems to work!

-------- 2d EDIT ---------

Nope… the above does not work quite. The problem reverts again.

1 Like

I have been seeing the same problem for a while now.

  • Toggling the “Private window with Tor” did not solve it
  • Turning off ““Continue running background apps when Brave is closed”” did not work
  • Deleting “C:\Users\myusername\AppData\Local\BraveSoftware\Brave-Browser\User Data” did not work

Just tested again with Nightly. Still no dice.
Version 1.29.50 Chromium: 92.0.4515.131

Still happening on:
Version 1.29.81 Chromium: 93.0.4577.82 (Official Build) (64-bit)
Removed all extensions, toggled the “Private window with Tor” to off, exited, killed the Brave Updater process, restarted, turned “Private window with Tor” back on. Still no love.

If you open a Tor window, let it sit for say 60 seconds, what do you then see when you open brave://tor-internals/ (the “Logs” tab)?

General Info:

Tor Version:
Tor Process Id: -1
Tor Proxy URI:
Tor Connection Status: Disconnected
Tor Initialization Progress:

Logs and Tor Control Events: still an empty box.

Devtools console has:

crbug/1173575, non-JS module files deprecated.       load_time_data.js:226

Apologies for the delay in getting back to you. One quick thing to check: are you able to open https://www.torproject.org/ in Brave and any other browsers you have on your machine?

That would be it. My OpenDNS settings were blocking “Anonymizer/Proxy”. Thank you very much, @fmarier !

Great. I have filed an issue to improve the error message in this case:

I encountered the same issue on Windows 11 (Brave version: 1.31.91) and managed to solve it by turning off the automatic proxy detection in the windows settings:

  1. Open Brave and navigate to Additional Settings → System
  2. Click on “Open your computer’s proxy settings” (Windows proxy settings are opened)
  3. Turn off the automatic proxy settings detection
  4. Restart Brave
  5. Open a new private window with Tor
  6. Tor starts initializing - et voilà! :upside_down_face:
2 Likes

This didn’t help. It still shows Disconnected.

1 Like

Seconding as one using. mac

All the abovementioned methods didn’t work for me. Kindly help if there is any. I have Window 10 EnterpriseOS.