Private window with tor never works


Private window with Tor is always disconnected
How can this issue be reproduced?

  1. Open a New Private Window with Tor
  2. It always says “Disconnected” at the bottom
  3. No sites will load

Expected result:
For it to use tor and load sites.

Brave Version( check About Brave):
1.38.115

Additional Information:
This started three updates ago. I keep assuming a new update will fix it, but it hasn’t so far.

@strycat ,

Using the Terminal.app, in a command line window, enter:

open -a "Finder" $HOME/Library/Application\ Support/BraveSoftware/Brave-Browser/

Within that Brave-Browser folder, look for a folder named: cldoidikboihgcjfkhdeidbpclkineef

That is the folder containing the component: Brave Tor Client Updater

In a Brave Browser > New Window, go to:

brave://components

In the list, you might see:

Brave Tor Client Updater - Version: 1.0.25

A component that does not exist (or not completely), may appear in your Components list, but NOT have a Version number/value . . . and that may mean, the Component is missing or not properly being updated.

Look over:

The Tor component is supposed to be replaced / updated, when you Disable . . . and wait a moment . . . then Enable the Private window with Tor switch:

Screen Shot 2022-05-09 at 1.45.18 AM

I tested that. The Tor component (items) disappeared BUT were not replaced . . . at first. I discovered that, AFTER Enabling the switch, I had to open a New Private Window with Tor . . . and wait . . . until the Tor component showed up. (Just tested that, again:)

Screen Shot 2022-05-12 at 11.11.43 PM

The folder cldoidikboihgcjfkhdeidbpclkineef exists and has a subfolder 1.0.25. However when I go to brave://components I see:

Brave Tor Client Updater (Mac) - Version: 1.0.25
Status - Component not updated

I tried removing the folder. It reappears if I open a new private window with tor. However it still won’t connect to tor.

I’ve also tried disabling secure dns and re-enabling it. Also tried the Private windows with Tor toggle. Doesn’t seem to fix anything.

What did finally work after trying all the above, was in the tor window, clicking on the three bars and there’s an option near the top “New Tor connection for this site”. Clicking that seemed to work.

Hopefully that keeps working.

1 Like

@strycat ,

Good work:

New Tor connection for this site

News to me. Thank you.

The “three bars” icon (upper-right of the Brave Browser window) is called a Hamburger Menu.

cc @Chocoholic