'Private Tab with Tor' reports failure to connect (but then connects)


#1

Since the availability of Private Tabs with Tor was announced I’ve rarely been able to connect using the feature.

When trying to use it, with few exceptions, I have seen the following appear:

“Unable to connect to the TOR network. Brave could not make a connection to the Tor network. Disable Tor to continue private browsing without Tor protection.”

So I disabled TOR and just used a standard Private tab.

However, the result of my last attempt left me wondering whether the error messages may actually have been incorrect.

This time, instead of disabling Tor and continuing in a normal Private tab, I pressed ‘esc’, assuming that would abort. Immediately after that I noticed a message in the URL line informing that a connection was being made and showing the progress toward making the connection (as a percentage).

I then tried to open another Tor tab and this time one opened right away.

Guess I will keep trying this to see whether hitting ‘esc’ has the same result when Tor appears to fail.


#2

The next time it happens, before you restart the browser, can you please share your tor.log file and, if possible, console output?

The tor.log file is located:

  • On macOS: ~/Library/Application Support/brave/tor/data/tor.log
  • On Windows: %appdata%\brave\tor\data\tor.log
  • On Linux: ~/.config/brave/tor/data/tor.log

There is no sensitive information in the tor.log, so it is safe to share here.


#3

Thanks. I haven’t been experiencing that specific issue recently. (I also didn’t “restart the browser” when it happened, I just selected the option for a non-TOR ‘private tab’ & continued using that.)

However, I have experienced TOR private tabs suddenly dying after I’ve been in them.

That is, I see the same error message I had reported seeing when they wouldn’t open, except now it appears at some point after I’m already in the TOR private tab.

Since it’s a private tab that means I ‘lose’ the webpage in whatever state it was in at the time when that happens.


#4

Can you please share your tor.log and console output to help diagnose this?


#5

> * On macOS: ~/Library/Application Support/brave/tor/data/tor.log

Thanks but I don’t see an entry for ‘Brave’ under Application Support.

Also, where do I find the “console output”?


#6

Hi @mk7z,

While Brave is running, could you type ps aux|grep brave within the terminal? This will output some information about the Brave process that’s currently running. Could you share the output with us? This will help us narrow down your profiles location. It should look similar to this:

kjozwiak 13337 0.0 0.1 4328276 9068 ?? S 12:28am 0:00.02 /Applications/Brave.app/Contents/Frameworks/Brave Framework.framework/Helpers/crashpad_handler --monitor-self-annotation=ptype=crashpad-handler --database=/Users/kjozwiak/Library/Application Support/brave/CrashPad --metrics-dir=/Users/kjozwiak/Library/Application Support/brave --url=https://laptop-updates.brave.com/1/crashes --annotation=plat=OS X --annotation=prod=Brave_Mac --annotation=ver=68.0.3440.84 --handshake-fd=34

If you look at the --database flag in my example, you’ll notice the /Users/kjozwiak/Library/Application Support/brave/ directory which is the directory where the profile is saved and where you’ll find the logs that @taylor requested above.

There’s two easy ways that you can find the terminal:

  • 1 - Simply search for Terminal using macOS’s search capability
  • 2 - Using macOS’s file menu, click on Go -> Utilities -> Terminal