Polish ING banking website unresponsive

Brave 1.35.104
MacOS Monterey

The major Polish bank website is slow loading and can stop responding when you try to log in (“Wait or exit page”), even in an Incognito window and with Brave Shield turned off. Other banking and non-banking websites work fine. The ING website works fine with other web browsers (Google Chrome, Safari). Why is that and is there a way to fix it?

https://www.ing.pl/ → Click “ZALOGUJ” in the upper right corner, then “Moje ING”.

@cacioepepe ,

REVISED 2022-02-27 Sunday
REVISED 2022-04-13 Wednesday

With Brave Browser running, in a New Window, go to brave://settings/clearBrowserData

Select the Basic tab. Enable all three of:

  • Browsing History
  • Cookies and other site data
  • Cached images and files

Click on the Clear Data button

Examine all the settings for the other two tabs: Advanced / On exit

Be certain that those settings are what they should be, for your usage. In time, you will have tested those arrangments, and figured out what you need, there.

IMPORTANT: The cleaning / clearing away of cookies, thru that process, WILL NOT REMOVE ALL of them! If you are intent on removing all cookies, then you must also, in a New Window, be sure to go to: brave://settings/siteData and manually remove sources for cookies, there.

Quit Brave Browser. Wait a moment. Start Brave Browser.

In a New Window, go to brave://settings/cookies

Scroll down that settings page, to Sites that can always use cookies

Click the Add button

Enter www.ing.pl as the site . . . but do not Enable

  • Current Private session only
  • Including third-party cookies on this site

Click the Add button

Repeat those steps for the following sources of possible cookies:

content.ingbank.pl
ospe.ing.pl

Next, go to brave://settings/content/javascript

Scroll down that javascript settings page to Allowed to use javascript

Click the Add button

Enter www.ing.pl as the site . . . but do not Enable

  • Current Private session only

Click the Add button

Repeat those steps for the following sources of javascripts:

content.ingbank.pl
ospe.ing.pl

Now go to brave://settings/shields

For Trackers & ads blocking set that to Standard

For Upgrade connections to HTTPS set that slide switch to Disabled

For Cookie blocking set that to Only cross-site

For Fingerprinting blocking set that to anything BUT NOT Disabled

Close the Brave Browser settings window.

Next, you will test both of two scenarios

First - by opening a New Window

Second - by opening a New Private Window

AFTER testing access to the bank, using the New Window . . . you will log out of the bank website (if you got that far) and then Quit Brave Browser . . . or simply Quit Brave Browser.

NEXT, you will start Brave Browser; and, you will test access to the bank, using the New Private Window.

By then, you will have ideas about, how to test further. YOU are the troubleshooter, for your issue.

Maintain detailed typed or written notes of your progress, your steps taken, the results for each. Report back here, with your findings. Thanks.

Help:

In order to learn, what website sources (of cookies and scripts) may be involved, learn to use the Developer Tools > Network tool for monitoring items, and use the Developer Tools > Application for learning sources of, and examining, Cookies.

How to use Developer Tools

"“https://www.lifewire.com/web-browser-developer-tools-3988965"”

““https://developer.chrome.com/docs/devtools/network/reference/””

““https://docs.microsoft.com/en-us/microsoft-edge/devtools-guide-chromium/””

Developer Tools > Network tool is where you search for sources of scripts and other items that will qualify despite their not being obvious scripts.

Developer_Tools_-Application-_Cookies__example_Amazon.com_00

Developer Tools > Application tool is where you will find the sources of cookies.

I checked the site, its not exceptionally quick site (the frontpage image failed to load). Not using a VPN by any chance?

Tried everything you have suggested and there is only one improvement. In a Normal Window the website does not crash and I have to wait only 10 seconds in order to get the LOGIN field. In a Private Window the website crashes.

Also, I have noticed that there is another banking website that crashes even worse than ING → www.santander.pl → Click “Zaloguj się” in the upper right corner, then “Santander Internet”.

I do not use VPN.

@cacioepepe ,

I revised my previous reply 2, above, adding a couple more sources for possible cookies and definitely for javascripts.

In order to learn, what website sources (of cookies and scripts) may be involved, learn to use the Developer Tools > Network tool for monitoring items.

That is how I found both:

content.ingbank.pl
ospe.ing.pl

How to use Developer Tools > Network

https://www.lifewire.com/web-browser-developer-tools-3988965

https://developer.chrome.com/docs/devtools/network/reference/

https://docs.microsoft.com/en-us/microsoft-edge/devtools-guide-chromium/

Took a screenshot:

Would test the site in Brave Nightly

See if it changes much

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.