Pls help block a site from spawning new tabs for ads keeps spawning new tab(s) for ads. Is there a way to prevent it from doing this?

Turn, adblocker to aggressive either from the top right sheilds icon or by brave://settings/shields.

Got o brave://settings/content/popups and select ‘Dont Allow’

thanks for replying.

Already the first part. However there is content/popupsbrave under settings :frowning:


In previous comment, I copy pasted it two times, I have edited it now

many thanks! I’ve turned it on for the mentioned site. will monitor and hopely will no longer see popups from this site.

hmm it didn’t work for this site it can still spawn a new tab for ads even after setting both as suggested :(. any other work around suggestion is appreciated.

saw similar topic below and seems brave support can help in blocking site from spawning new tabs:


I have tagged brave team adblock member, he will solve it.

The site is using randomised adservers, using the latest Brave Ad Block Updater - Version: 1.0.1427. I didn’t get a popup.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.