PiP (Picture in Picture) mode doesn't work on YouTube anymore

Description of the issue:
Opening Picture in Picture opens a white box on the bottom right that doesn’t show anything

Oddly, when I switch the quality to 240p, it starts working (even if I switch back) as shown below

Also, it seems to work perfectly fine on Reddit.

I tried solving it as described in this thread including -

  • Disabling Hardware Acceleration
  • Opening in a new user profile
  • Opening in incognito
  • Enabling, disabling auto-hide Ubuntu task-bar.

None of the above worked

Brave Version( check About Brave):
Version 1.0.0 Chromium: 78.0.3904.97 (Official Build) (64-bit)

Environment
Ubuntu 18.04.3 LTS
Gnome 3.28.2
Quadro K620/PCIe/SSE2
Intel® Xeon® CPU E5-1650 v4 @ 3.60GHz × 12
Memory 31.3 GiB

Additional Information:

same issue, works a-ok on pretty much all websites, but youtube doesnt even have the PiP option anymore and if you force it its all fuck-y

Have you tried 3rd party PiP addons?

Have you tried updating the browser? I’m currently using Debian 10 with Brave Version 1.0.1 Chromium: 78.0.3904.108 (Official Build) (64-bit) and it’s working fine.

Not really. Tried the official Google PiP extension but that had the same effect.

Just ugpraded to Version 1.0.1 Chromium: 78.0.3904.108 (Official Build) (64-bit), doesn’t solve it.
Although it does introduce a new bug of being unable to move the tab without detaching it from the window. Can’t reattach it back to the window either.

same issue, window becomes unmoveable and doesnt display the video, it gets fixed if you move it around using Win + Arrow keys a bunch, I have no clue why tbh

Have you tried the normal version of Chrome to ensure that this is a issue with Brave and not Chrome in general? What version of the NVIDIA graphics driver are you running?

not a single issue with chrome, this is 100% a brave thing, tried on ~5 different pc’s, all running Win10 and the latest version of brave, all had the same outcome, it didint happen on chrome with any of them,
used intel cpu and amd cpu, same outcome
used nvidia gpu and intel integrated GPU, same outcome

I really think this is a bug with Chrome itself. Read this Reddit post for more information.

@ThaUnknown Is the issue resolvable by changing the video resolution after starting PiP mode? That is the only known fix that I can find at the moment. It won’t fix the issue, but at least it will allow you to use feature.

Just tested by on a fresh install of chrome.

As of Chrome Version 78.0.3904.108 (Official Build) (64-bit), it seems to be working perfectly with no problems.

Since brave is based on the same version, I doubt this is a chrome problem.

That’s good to hear. Honestly I didn’t cross-check the Chrome and Brave versions so that was my slip, sorry. Still trying to think what would have been the cause of this issue as I have yet to have any problems with the browser on either Linux or Windows, but glad to hear it resolved itself.