Persistent history in search field, how do I delete this?

These entries were from various sites weeks ago, I’ve cleared all caches, removed all extensions, refreshed, searched on DDG and still see no way to remove this dropdown when I click on this search field. Any suggestions?

Thank you!

Hello @SR_Johnson

i know you said you cleared the cache but just to make sure
when you cleared the cache go to
brave://settings/clearBrowserData
then advanced then choose all time then make sure to select passwords and other sign-in data

hope that help and have a nice day :slight_smile:

Yes, cleared all time most every checkbox for the “advanced” tab.

could you disable all extension and clear all cache again and see if it show up
cause that very weird

if it still show up let me know

@SR_Johnson,
Do you see those same suggestions when you enter text into a form field on a website? Or when you search via the address bar?

Because while I see search suggestions in my address bar or in a form field, I do not see those suggestions – or any suggestions – when I go enter text into my password search field.

So to update, the one thing I hadn’t “cleared” was address/cards and passwords. I just disabled all extensions and cleared the “addresses” as requested above and the data is now gone. So this issue has been resolved.
However, I’m not sure why a “search” field is cross linked to an address autofill, seems like there could be a better management of these forms.

Thank you!

1 Like

glad that you figured it out but what address you cleared could you give me the name as it exist in the setting page

thanks and have a nice day :slight_smile:

I hadn’t cleared the address auto-fill option previously, in this last iteration I also checked the box for address auto-fill. That was the only difference. Also to the previous question I was not getting drop-downs nor auto-fill on any pages that I tried other than the search boxes on Brave settings.

got it and thanks for the clarifying and have a nice day :slight_smile:

@SR_Johnson,
Glad you got this resolved. Again, I’m not entirely sure why those Autofill options appear in that particular search – try as I might I’m unable to get them to appear myself, and that’s without clearing any browsing data.

I’ll reach out to a couple of team members to see if we can divine the logic here – if I get an answer I will re-open this thread and respond with that answer. Closing for now however. Thank you again for reporting :slight_smile: