Password saving doesn't work on one profile

Current Brave Version (v 1.67.116)
OS: Windows Pro v22H2, build 19045.4529

The feature has its settings UI, but does nothing:

  • Identifying on a site has only the basic field auto-complete (for name, not password), not the one specific to name+password pairs.
    Once entered, no offer to save password.
  • The brave://password-manager/settings “Never Saved” list is not there, meaning it is empty.
  • brave://password-manager/passwords is empty.
    Manually adding en entry adds nothing.
    Importing a password file adds nothing.
  • brave://settings/clearBrowserData is set to not clear anything on exit.
  • Other Brave profiles work just fine, including new ones.

I tried (restarting each time):

  • Disabling all extensions.
  • Clearing ALL cached data.
  • Changing the brave://password-manager/settings back-and-forth.
  • Resetting ALL settings from brave://settings/.

I read and found no fix in:

First, can you please tell me what OS you’re using at this time?
To confirm, you’re saying that password saving doesn’t work in one browser profile, right? Not the OS profile?

Further, given this I assume that saving passwords works as expected in other profiles is that correct?

OS: Windows Pro v22H2, build 19045.4529
Browser profile, yes.
All other profiles I tried work, including new ones.

Apologies for the late reply here — just got back from PTO.

Can you please confirm that the issue still occurs at this time? If so, can you please tell me exactly what happens when you try to add a password manually within the browser? Once you click Save, what happens?

Issue still occurs.

Once I click Save , I am back at the password list, and it is still empty.

Do you have an OS password set on the device that you’re using at this time? I ask because the OS password is used to encrypt password data in the browser. This could explain why the data can’t be saved.

No.
I only use one Windows profile.
If this was the problem, it would affect all Brave profiles.

I did get “path not found” errors trying to copy the folder of that Brave profile.
But strangely it seemed irrelevant (mostly removed extensions), and substituting the copy did not remove this password bug.

Note: I will eventually just move to a working profile.
This discussion is just to frame the bug.

@Bruno_Mailly,
So on your other working profiles, if you go to brave://password-manager/passwords and try to view a password, you’re allowed to view it without being prompted to enter the system login password?

Ah my bad, Windows does ask me a password for this, even if it’s just a PIN.