Passwords are not being saved to autofill

Description of the issue:
How can this issue be reproduced?

  1. I enter a username and password and
  2. The dialog box pops up asking me whether to save it
  3. I save it but the password autofill section under settings remains empty.

**Expected result: Credentials would be saved to password autofill section

**Brave Version( check About Brave): Version 1.35.100 Chromium: 98.0.4758.87

**Additional Information: I’m not sure if this is related, but sessions for tabs seem to end much more quickly than then they used to. I’m getting logged out of sites all the time. I’m using MacOS 10.14.6.

1 Like

please check setting/additional setting/autofill then check offer to save password is On? if not so turn it on

Hi, Thanks for your response. It has always been on. I also turned it off and on and then rebooted.

1 Like

Hi, following up on this request.

@tljbrv Hi :slightly_smiling_face:

Are you still having this problem? There have been several version updates (currently at 1.36.112) and I was wondering if you are experiencing the same issue now.

Hi, I just updated to the latest version (v1.36.112) and tested it. Unfortunately, passwords are still not saving to Autofill.


Can you check the version? Current version is 1.36.119.

Basically, for preliminary, I’m just going to share moderator posts of things to test from similar topics. Then if none of that works you will have to tag a moderator for help.

This post has some additional information you might want to read. I don’t know anything about macOS, so do not know if it applies to your situation or not.

Finally, there is an option to import passwords into autofill that you might want to try if you have the same information stored somewhere else on your system. It asks for a .csv file.

  • Now on v1.36.119
  • Checked Settings → History → Clear browsing data Autofill and form data option are not selected in the On Exit
  • I have two extensions installed. Clear Cache and Awesome Screenshot. I’ve had installed long before this issue started.
  • I tried importing passwords and that feature doesn’t seem to be working either. I uploaded a csv file and the password interface is still empty.
  • I also enabled adding passwords manually and that doesn’t work either. After i save, nothing.

I’ll look into creating a new profile.

HI, created a new profile and non of the password features worked there either…

Well, was worth a shot. Too weird. I’m tagging @steeven @Mattches for you. Hopefully that can help you solve the problem.

Thanks for helping me out on this.

This sounds like a keychain access issue. Can you (on your macOS system) open the spotlight search (Cmd + Space bar), type in Keychain access and hit enter. Then select Login on the left-hand side of the window, then check to see if Brave Safe Storage is listed here?

It appears to be there. See screenshot below.

Hi, I updated to V1.37.111, but the autofill password feature is still not saving passwords.

Any update on resolving this issue?

I ran a test between my laptop and my desktop, both macs. I’m running Big Sur v11.3 on my laptop and Mojave 10.14.6 on my desktop. The password feature works on my laptop, but still not on my desktop. Both are using the same version of brave 1.37.113. So maybe it’s an incompatibility with the Mojave OS that causing the issue. Any chance this information might help in finding a fix?

Sorry for the late reply. It could be related to the OS yeah — I’m assuming the Brave safe storage is present on your Desktop as well? Can you try disabling your extension (on desktop) anyway and testing to see if this makes any difference?

Hi, yes the Brave safe storage is present. I posted a screenshot earlier verifying that. What extension should I disable? Sorry if I missed something.

All of them just to ensure that’s not what’s causing the issue.

So, I had to restart my computer and when it had rebooted I noticed that brave autofilled a password. I checked my passwords and all of my passwords are back. All of them, from all time. I also deleted one and logged into the site and it also saved to autofill.

I did not remove any extensions, so that wasn’t the problem.

Not sure why rebooting my computer would have fixed the issue, but hope you find this info useful.

@tljbrv ,

May interest:

Brave Browser wants to use your confidential information stored in "Brave Safe Storage" in your keychain?