Option to NOT match Brave's theme with windows?

It looks like with the latest update Brave is using high contrast Windows theme to display websites.
Really hate it. High contrast theme works for windows, but it’s trash for websites.

Can we have an option to NOT use windows theming?

Description of the issue:
I use Windows 10 High Contrast settings to change the appearance of things like Word documents (it appears blue to me, but is ‘actually’ white if I send it to someone else). It also changes the background of folders.

This has never affected Brave before today, but now the browser background is blue and making it incredibly difficult to use, especially in gmail and google docs. I tried installing several themes, but they only change the appearance of the browser bar, not the background. It also isn’t an issue in Chrome. Please can someone help with this?

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:

Operating System and Brave Version(See the About Brave page in the main menu):

Version 1.21.73 Chromium: 89.0.4389.72 (Official Build) (64-bit)

Additional Information:

@cmd,
Thanks for reaching out.
I think the behavior should be for Chrome, Brave or any browser to display itself in high contrast mode when it’s enabled. On my end, it seems to be an all or nothing thing – either high contrast is enabled system wide, or disabled system wide. Are you saying that prior to the update, Brave would launch without the high contrast theme, even though it was enabled on the system?

@cmd @Hunam,
I went ahead and merged both of your threads since you’re both reporting the same thing around the same time. Can one or both of you confirm for me that this behavior only happens in Brave? It’s my understanding that any app opened when high contrast mode is enabled will receive Windows theming – I’m trying to find out which is the case here:

  • All apps on Windows get high contrast treatment when enabled, but this feature was not working in Brave previously, which is why it didn’t get applied. The update fixed that error which is why you’re now seeing Brave windows in HC.
  • Only some apps get the high contrast treatment when enabled, and now Brave has been added to that list for one reason or another.

@cmd @Hunam,
Please see here for a potential workaround/solution:

Hi Mattches - I still have the same issue when Brave appearance is set to light or dark (only the address bar changes, not the background).

This only happens in Brave as of today, but it’s not an issue in Chrome.

1 Like

This is a serious issue, so much that registered for an account just to reply to it.

Brave was fine until late last night, then everything was broken.

I have a high contrast theme in Windows 10. White text, gray background. Pretty much identical to the screenshot that Hunam posted. Windows 10 theme management is trash, but the high contrast setting is mandatory for certain window elements to have custom colors.

The fact that it overrides colors in web browsers is an ABSOLUTE NIGHTMARE. Websites are designed with specific color themes to give their own contrast to different elements on the page (borders, links, buttons, interactive elements, mouseover highlights, text boxes, etc).

When the high contrast theme overrides the color, everything is flattened. Colors are gone. In many cases borders, highlights and interactive stuff disappear completely. Nothing left but a sea of gray (background color). For being “high contrast” it’s actually harder to tell things apart. And if text elements are rendered over an image, it’s downright UGLY.

Here’s how it works in other browsers:

Edge: If high contrast is enabled, ONLY uses high contrast. No way to fix it. It sucks. BAD.
Firefox: Websites render their original colors in 95% of cases. Some minor glitches. Mostly GOOD.
Brave: Just like Firefox until last night. Mostly good. Now it’s like Edge. BAD.
Chrome: Websites render their original colors. GOOD.

Brave’s light and dark setting only affect the title, URL, and address bars. High contrast overrides everything else on the actual webpage.

Firefox and Chrome still render their original colors. Brave does not. High contrast is good for the operating system, bad for webpages. If the rendering engine was “fixed”, please give us an option to unfix it. This is serious usability issue. Yes Windows 10 sucks. But having it affect webpages sucks even more. I’m considering going back to Firefox because of this.

Correct.

This would actually work:

Now, none of those settings affect Brave browser area. Just this header area:

Youtube in Dissenter:

Youtube in Brave:

On the point of usability, here’s what the Brave setting page looks like with our style of high contrast gray background.

Notice the Startup radio button selection doesn’t render at all.
The slider checkboxes below it are virtually invisible.

1 Like

Hey Matches,

Unfortunately that fix doesn’t work at all.

Like the others have mentioned, previously Brave would launch without enabling Windows High Contrast Theme.

This is exactly how it should launch… without the Windows Theme. Why? As mentioned, there are millions of different website themes and features built to suit that website. Windows High Contrast Theme on the other hand is made specifically for Windows themes and features, hence why Windows High Contrast is ok on some website, but for the majority it is garbage.

It appears that the Brave development team saw that lack of this feature as a problem and enabled it… I however did a search and couldn’t find very much on people asking for it. This is beside the point, I mention it only because if the development team enabled it, then it should be pretty easy and quick to fix by doing one of the following;

  1. Disable this feature. It is not even needed in Brave as the Brave Appearance Settings already is outstanding for selecting a Dark or Light background. You can also change font colors and a host of other appearance settings that work for people who use High Contrast.

  2. Provide a “Switch/ Toggle” to Enable or Disable this feature. In doing this you will satisfy both groups that would like to use Brave with or without Windows High Contrast.

  3. Provide a way for us to revert back to a previous version of Brave while you decide on the best steps moving forward.

Just so you are completely clear on the error.

Prior to the latest Brave update;

  1. If Windows High Contrast was Enabled, it did NOT effect the Brave Theme.

After the latest Brave update.

  1. When Windows High Contrast is Enabled it overrides the Brave Theme and renders most actionable buttons, text and website features unusable or/ and unreadable.

All users of Windows High Contrast that use the Brave browser would appreciate a swift fix to this issue.

Thanks,
Steve

1 Like

I’ve already logged this issue on our Github for the team to review and address:

2 Likes

Hello there, I’m new here, but might have found the solution for you. I’m also an Chromium user (Opera and Chrome). While Opera is still not affected by this issue, the original Chrome got overriden by the Windows 10 High Contrast with the Chrome update 89.0.4389.82 from 12.03.2021.
All you have to do is to use the experimental settings (works for both Opera and Chrome, hopefully also for Brave) by typing:
chrome://flags/
and disabling Forced Colors
You can also experiment with dark settings for some colour changes.

5 Likes

That worked perfectly!

1 Like

Hey Un1 and Matches,

That fix worked perfectly. So simple and easy to do.

For the non tech types. Just copy and paste chrome://flags/ into your Brave Address bar and hit enter.

In the search field that comes up in the next window just type “Forced Colors” and that will pop up.

It sill probably be set to “Default”. Change it to “Disable”. Close Brave completely and then restart Brave. Presto… NO Windows High Contrast.

Great fix.

On a side note, and this may or may not be related to the last update, but at the same time the High Contrast issue started to happen I have noticed that whenever you “Hover” your mouse over clickable links and images, the link and image disappear. It only appears again after you move your mouse off of it. The embedded hyper link still works, it just totally disappears.

Note in the below image how the Text Lin k on the left had side menu area has disappeared now I’ve hovered my mouse over it.

(Hope the linked image shows up)

Any ideas if this has something to do with the High Contrast issue or is it related to something else?

Thanks again for an awesome fix.
Cheers

1 Like

I just noticed that in the image it doesn’t show my “Mouse” pointer.

It is the “Black” area under the text on the left that says 'Updates" and above the text that says “Business app store”.

The blacked out area actually says “Inbox” and you can only see the text if you move your mouse off of it. See image below.

Happens on just about all websites. It’s only when it is a “Clickable” image/ Item

Thanks
Cheers

1 Like

I had been wondering if there would be a solution since Chrome ended up having a similar problem.
Just saw the Forced Colors solution. Outstanding! Everything that update had broken for me, has now been fixed. Brave is back!

1 Like

omg I love you!!!

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.