Home page and webpages not rendering correctly

**Description of the issue: After upgrading to V1.21.73, land page and all websites display incorrectly, with blank backgrounds on images, or text in wrong position.
I have tested with disabled hardware acceleration, but problem persists.

How can this issue be reproduced?

  1. Always

**Expected result: Background colors and text displayed correctly.

**Brave Version( check About Brave):V1.21.73

**Additional Information: Screenshots:

@waltercas,
Thank you for reaching out to us.
Can you tell me if you have any extensions (other than Metamask) installed at this time?
Additionally, can you try creating a new browser profile and see if the browser has the same display issues when using the new profile? Make sure you close all other Brave windows during the test, so that you only have one window with the new profile open.

Hello, tried a new profile with no luck, only a Brave “error” warning appeared, regarding Google Drive extension.
These are my extensions:

Hi, I’m experiencing the exact same issue. It started spontaneously. I didn’t change any settings at all.

And Chrome doesn’t appear this way for either of you? I’ve reached out to the team for more information here – very strange issue. @edininja, would you mind also sharing a screenshot of how the browser looks when you experience this issue on your end?

@Mattches following your suggestion i´ve updated Chrome, and then Chrome incorrectly displays background colors and images! So the bug resides there

1 Like

Hey @Mattches, thanks for the reply.
My Chrome is not any different to what it was yesterday, since then I have turned sync back on and chrome also has the same issue :confused: I tried changing themes in Brave. The top part with the tabs changes but the websites are still displayed with black background and yellow font. I don’t mind this look, however, it removes functionality from websites (see Brave settings image for example, I can’t see the enable/disable toggle).
Really frustrating!

Update: turning off the high contrast settings in Windows 10 seems to fix the issue. When I turn high contrast back on (Brave colour setting is NOT set to “same as windows”), the websites are once again displayed in high contrast seamlessly without restarting the browser.
It’s strange because I’ve had my Windows in high contrast for years without any effect on browsers (unless I turned on high contrast myself through an extension).

@edininja,
Thank you – that is excellent information. I’m not sure what changed with the Chromium/Windows behavior but it must’ve come along with the latest chromium update pushed into Brave. Good to know the solution is fairly straight forward though.

@waltercas ,
Can you please go to Settings --> Appearance and change the Brave colors option to Light or Dark (just as long as it’s not set to Same as Windows) and see if this also resolves the issue on your end?

@Mattches Changing Brave colors to Light or Dark did nothing.
Turning off High Contrast settings in Win10 like @edininja did, solved the problem.
Thank you both for your support.
Hope this bug gets solved in Chromium soon.

We’ve filed the following to capture data on this issue:

We appreciate your patience and hope to get this sorted as soon as possible.

Disabling ‘forced colours’ in brave://flags has sorted this issue out for me finally

1 Like