Online Payment Gateway(Visa) Error

Cannot do any online transactions from Visa Cards

From 12th May, Thursday whenever I am trying to do online payments using IPGs(migs.mastercard.com/au), I am always getting this error. It is working with other browsers. My card is working. I reinstalled brave, removed all plugins and tried, Still having this error. I have attached the screenshot below:

image

This is happening every time when I am trying to buy something online and the merchant redirects to this IPG.

Windows 11 v25120.1010
Brave Version – Version 1.39.111 Chromium: 102.0.5005.61 (Official Build) (64-bit)
Additional Information:

@FieryPrince

Please explain what you mean, by ‘IPG’

IPG – Internet Payment Gateway

1 Like

@FieryPrince

Recommended in order to Start Up Brave Browser lean instead of burdened:

In a Brave Browser - New Window, go to: brave://settings/getStarted

  • Select: Open a specific page or set of pages
  • Select: Add a new page
  • Enter: about:blank (notice the colon)

Recommended Brave Shields version is v1

In a Brave Browser - New Window, go to: brave://flags

Search for Enable Brave Shields

  • DISABLE: Enable Brave Shields v2
  • ENABLE: Enable Brave Shields v1

Recommended GLOBAL SHIELDS settings:

In a Brave Browser - New Window, go to: brave://settings/shields

  • Enable: Show the number of blocked items on the Shields icon

If ‘Default view’ option is available, select: Advanced view

  • Disable: Auto-redirect AMP pages (AMP - Google’s Accelerated Mobile Page)
  • (Alternate setting for older Brave Browser versions, try: Disable Enable De-AMP at brave://flags)
  • Enable: Prevent sites from fingerprinting me based on my language preferences
  • Trackers & ads blocking: Aggressive
  • Enable: Upgrade connections to HTTPS
  • Enable: Block scripts
  • Block fingerprinting (aka Fingerprinting blocking): Strict, may break sites
  • Block cookies (aka Cookie blocking): Only cross-site

Recommended in order to reduce influence by websites:

In a Brave Browser - New Window, go to: brave://settings/content

Scroll down to “Additional permissions” . . . and set:

  • Protocol handlers: Don't allow sites to handle protocols
  • File editing: Don't allow sites to edit files or folders on your device
  • Clipboard: Don't allow sites to see text or images on your clipboard
  • Window placement: Don't allow sites use info about your screens to open and place windows

Scroll down to “Content” . . . and set:

  • Pop-ups and redirects: Don't allow sites to send pop-ups or use redirects

In a Brave Browser - New Window, go to: brave://settings/cookies

  • Enable: Block third-party cookies
  • Disable: Clear cookies and site data when you close all windows

In a Brave Browser - New Window, go to: brave://settings/cookies

Scroll down that settings page, to Sites that can always use cookies

Click the Add button

Enter [*.]mastercard.com.au as the site . . . but Do Not Enable

  • Current Private session only
  • Including third-party cookies on this site

Click the Add button

Repeat those steps for:

  • www.google.com:443

Next, go to: brave://settings/content/javascript

Scroll down that javascript settings page to Allowed to use javascript

Click the Add button

Enter [*.]mastercard.com.au as the site . . . but Do Not Enable

  • Current Private session only

Click the Add button

Repeat those steps for:

  • www.google.com:443
  • www.gstatic.com:443

I used Brave Browser > Developer Tools, in order to identify the sources for cookies:

1 Like

@289wk Thank you. It worked. :clap:t5::clap:t5:

1 Like