Nothing happens after clicking on buttons under rewards settings


Description of the issue:
Nothing happens after clicking on buttons under rewards settings e.g., I click on “Add Funds” and nothing …

How can this issue be reproduced?

  1. Go to rewards settings
  2. [This is related to the wallet window on the right]
  3. Clicking on Verify Wallet, Add Funds, Withdraw Funds or Verify does nothing
  4. Clicking on Settings (the wheel), View Monthly Statement for Details or here work as expected.

Expected result:
That it actually works

Brave Version( check About Brave):
1.17.75 but this was an issue with previous versions as well.

Additional Information:
I do have a wallet with uphold but cannot transfer for the time being due to jurisdiction.
I’ve already tried disabling extensions to no avail.

Hello, has anyone run into the same issue and can give me a hand with? Thx

Try opening the browser anonymously or in Tor, if it doesn’t work, come back to find a solution.

Yeah I tried incognito and Tor but rewards don’t exist under those modes …

What’s the best way to bring this to the brave team’s attention? I’m able to update to the new versions of the browser but this issue still persists. Kind of a bummer since the balance’s been accumulating but there’s nothing I can do with it.

1 Like

I’m having the same issue. Nothing happens when clicking on any of the buttons related to this stuff.

Well at least I’m not alone. Haven’t found a solution yet but hopefully someone will shed some light on this issue. Hard to back brave when basic functionality is flawed.