Problem with verify wallet button

Hi, I’m having problem verifying my wallet. When I try to click on “verify wallet”, “add funds”, or “withdraw funds”, on the reward page, none of the buttons do anything. I’m wondering if it has anything to do with my uphold account.

Any advices would be appreciated!

When opening a topic on Rewards, please include as much information about your situation and setup as possible. Rewards issues can be extremely complex and sensitive.
Please also ensure that you’ve read through the following topics/pages thoroughly before opening a topic as your question may have already been answered:


1 Like

@moonstill,
We’re seeing a couple other threads where certain Rewards panel options are not responsive. Can you please tell me what version of the browser you’re using at this time and whether or not you have any extensions installed? Also, is your wallet verified with Uphold?

Hi Mattches,
I was having the issues with an earlier build. I just updated to the latest version(1.21.77) and the problems still exists. I do have few extensions installed and running. As regarding to the last question, I don’t think my wallet nor my uphold account is verified since I’m currently a resident in NY. I’m wondering if this is the cause for the problems.

@moonstill,
So the Rewards panel should still work despite you being an NY resident. That said, if it did, you would not be able to verify at this time – but it seems like you’re already aware of that.

I’m wondering if you can try creating a new temporary browser profile and see if you’re able to opt-into Rewards there and see if the Rewards panel buttons are functional. This will at least help point us in the right direction.

@Mattches
Creating the new profile does make the buttons to work. when clicks on “verify wallet” or “add funds” , it prompts me a small box with option to login to my uphold account. (see attached image) However, after I login in to my account, the reward panel remains the same, and the login button stops working.

Hello I am having the same issue. Verify Wallet, Add Funds, Withdraw Funds, and the (verify) button all do NOTHING when clicked.

I downloaded the latest version of the browser as well.

I posted the same issue some time ago and never got an answer. Would be great if this was addressed. NY based account as well.

@sQUansEA @Xander756 Please answer the following questions for @Mattches:

  1. What version of the browser are you using at this time?

  2. Do you have any extensions installed?

  3. Is your wallet verified with Uphold?

@moonstill There’s a newer version after that one that was released a couple of days ago. Try that one.

I am having the same issue, i have BEEN having this issue for months. None of the brave updates seem to fix it. My uphold wallet is fully verified.

I am also a NY based account as well so it seems like there are 3 of us with this issue…

The newest version. I just re-installed to make sure I was up to date.

I have a few extensions but I have tried disabling them all and then trying again and no luck.

I’m not verified. When I try to click verify the button does nothing.

  1. Latest version installed; I’ve been using Brave for two years so I’ve gone through many versions.
  2. I’ve tried with all extension disabled to no avail.
  3. Verify wallet button does nothing now although I recall being to login from that same button at some point. NY seems to be the common denominator.

My earlier post on this issue:

@rosiecar
Just tried out the newest version, It didn’t solve the problem :frowning:

@Mattches will anybody be looking into this? thx

I opened the following issue to capture data on this:

1 Like

For anyone experiencing this issue, can you confirm whether or not you’re on macOS or Windows?
If macOS, it may be an issue with whether or not the browser has keychain access to your system. Can macOS users please try the following:

  1. Open Keychain Access.app
  2. Search Brave Safe Storage
  3. Double-click the entry found, click on Access Control tab
  4. Press the + button in the bottom-left corner, and find Brave Browser in your /Applications directory
  5. Upon seeing Brave Browser added to the list, tap Save Changes and enter your password
  6. Re-launch Brave

I am using windows.

I also do live in NY.

1 Like

I am using Windows and am having the same problem