Buttons in Brave Rewards Settings Not Working

None of the buttons are working the Brave Rewards settings page on Mac OS 10.14.6. I’ve had this issue for a while and none of the updates have fixed it. I can’t click on any of the “claim” notifications and I can’t verify my wallet or really do anything in that wallet window. I would love to be able to actually verify my wallet and get my BAT stored properly.

Thank you for reaching out.
Can you tell me if you have any extensions installed at this time? Additionally, if you visit the Rewards settings page and open dev tools and try to click around, do any errors appear in the console window?

If you’re unfamiliar with dev tools, simply:

  1. Go to Rewards settings page
  2. Press cmd + option + i
  3. Click the Console tab in the dev tools window that appears
  4. Now click around on some of the options on the Rewards settings page and see if any console output appears.

Share a screenshot of the console output here with me if anything does appear.

Thanks for the quick response. I have 6 extensions installed. I eliminated some already but no change. I opened dev tools like you said and clicked around while in the Console tab but there was no change. None of the rewards buttons worked still. Here is a screenshot:

Hi Again,

Just wanted to check in on this issue and see if there is anything I can do to fix it. Thanks

Can you please tell me what version of Brave you’re using, what extensions you have installed (if any) and whether or not you’re using a VPN at this time?

Sure thing, it’s currently on


TopCashback USA

And no VPN

Can you try disabling your extensions and testing to see if the issue persists?

Sorry for the late followup. I disabled everything and unfortunately still have the same issue. No buttons working at all. I updated and restarted browser after disabling as well and still nothing.

No worries – to confirm, the buttons that are not working are only the Claim buttons, correct? Or is it the entire Brave Rewards settings page that is unresponsive?

@BonJon , when you go to brave://rewards-internals > General Info, is your key info seed considered valid? And do you have a Wallet Payment ID, or is that blank, errored, null, not yet created, etc.? Thanks.

1 Like

I’m sorry, I’m not totally sure what the key info seed means but it does say “wallet was not yet created” under Wallet info and “Wallet status: No wallet” under External wallet info.

Also regarding the previous post from Mattches, I tried to turn off and on the switch enabling Ads to confirm if the rest of the page works and it turned off, but now won’t turn back on again. Other than that, the Verify Wallet, Add Funds, and Withdraw Funds buttons don’t work and the QR code button works, but the window that pops up just says Loading image… forever.

It sounds like a OS decryption permissions issue, which is most common on MacOS. In short, do you ever see that little popup when you boot up Brave that prompts you for your password? You probably pressed “reject” or “cancel” or “ignore”. If you did that, Brave can’t decrypt your wallet. And one of the side effects is that the buttons stop being responsive. It’s very similar to this: https://github.com/brave/brave-browser/issues/15214

A workaround would be to allow the OS encryption/keychain, etc. for Brave.app.

Ah got it. So how would I do that? I restarted Brave and that prompt came up again, but I unfortunately don’t know what that password would be. Is there a way to reset it or dig it up?

Just wanted to follow up and say this was the trick! I put in my mac password and the page worked perfectly. Was able to transfer into Uphold and turn on the ads again. Thanks for your help!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.