Not getting any BAT on Windows

Since october 22 I’m not getting any BAT when viewing sponsored images in Brave on windows 10, while I still get them on my Ubuntu laptop linked to this device.
I have the latest version on both devices, and my wallet is verified with uphold.

Maybe you can try disabling an extra adblocker you got installed (I do not mean to the one that Brave already has, i mean if you got other installed like Adblock plus). You can try going to Brave rewards (brave://rewards) and modify the adds they show you per hour to the max.

1 Like

Tried to disable Adblock+ and nothing changes. I don’t think it could be a problem since I had it when it worked too. (I alredy have the frequency to 10/hr which is the max).

Looking at the Rewards.log file it says something like:

[06 nov 2021, 10:05:04,6 AM:ERROR:refill_unblinded_tokens.cc(232)] Failed to get signed tokens

for every time it loads an ad.

2 Likes

Am I the only one with this problem?

Common adblockers should not hinder you from recieving ads. I personally use AdBlock Plus, Adblock and uBlock Origin. And I amassed

this much the last month.

What helped me regarding sponsored images was setting my device region etc to the country I am in. I used to have my windows region on US. And I frequently had this issue. When I turned it to Germany, I had it less.
You could try that.

Also, cleaning the Browser cache regularly helps aswell.

The country is always been set to my actual country. Tried clearing the cache, changing region to US (nothing) and then back to mine (still nothing). It used to work fine until october 22, now it’s only broken on windows.

Ok I think I got what the problem is. There’s a limit of 4 devices linked to the same uphold account. I recently got a new phone and somehow I lost access on the PC (it didn’t tell me until I resetted my rewards, and now it doesn’t let me verify the wallet with Uphold again).

Is there no way to unlink a device, even if it’s an old phone, or at least check the linked ones in Brave or Uphold?
A staff member answer would be appreciated.

Found this “solution” (it only removes one device apparently). I’ll try it later on my laptop to see if it works.

I filled the form about 2 weeks ago and I still can’t verify my wallet.
I didn’t receive any response by e-mail either

Okay I found a way to get around the whole not getting your BAT thing because of uphold and gemini wallet limits… Never link your BAT wallet directly to your gemini or uphold account… Instead create a Brave Creators account and link that to YouTube Channel and your Uphold/Gemini account. Now you will get 95% of your BAT and never have to worry about wallet limits again. Just use the Brave tips function to tip your YouTube channel the BAT.

Finally got a response. One slot was freed

Tomcat87,
Did they provide any useful insight?

Was your first reply on Nov 10th of this thread the solution that worked for you?

I have this issue but with Gemini. Windows 10 and cell are only linked devices. shinymewy, appreciate the work around!

Yes, I filled the form I linked Nov 10 and yesterday they replied. I think they’re getting a lot of this kind of request. They only freed one slot tho but they also said they’re planning to remove the limit in future releases

1 Like

How much brave team take time to unlink device

Today my brave wallet disconnected and when I try to reconnect uphold shows me something went wrong message
My brave wallet already verified

If you recently got a new device maybe it’s the same problem. Try filling the form