No tip button, "No activities yet.." in rewards summary

My YouTube channel ( is showing as verified in one laptop, the Brave Rewards icon has a check on it and the tip button is available. However, in a different laptop, the Brave Rewards icon doesnt have a check (unverified?) in my channel. It doesnt show the tip button as well and only shows the message “no activities yet…” in the rewards summary.

How can this issue be reproduced?

  1. From first laptop, login to YouTube account/channel. Brave Rewards icon shows check (verified). The tip button is visible.
  2. From another laptop, login to YouTube using a different account, go to channel, the Brave Rewards icon doesnt show a check and no tip button.

Expected result:
Both or multiple laptops should show the same YouTube channel as verified and the tip button should be available in all machines.

Brave Version( check About Brave):
Version 1.20.108 Chromium: 88.0.4324.182 (Official Build) (64-bit)

Anyone can advise on this?

You should see a refresh button on Rewards panel. Does it help?

There’s no refresh button in the Rewards panel. I tried in a third laptop (work laptop), and had the same experience. No tip button and unverified channel. The screenshot below is from that third laptop (work laptop), only difference is the other laptop I have issues with has a verified wallet.

On my end, your channel appears as verified:

The way the browser detects verified creators or not is by downloading and referencing a known list of verified Creators. Sometimes, if the list is not updated, sites will appear as unverified.
The Refresh status button only appears when a Creator is detected as not verified and appears in the Rewards panel on the Creators channel:

Thanks for the reply! Yes, the channel is already verified, I can also see that in one of my spare laptops as well. But not in the other 2 laptops I tested.

Anyway, is there a way to force update this list to those machines that is having this kind of issue? I’ve tried searching for past similar issues here, and saw that there is this publishers_list file that needs to be deleted. However, I am not able to locate this in all 3 laptops that i’ve tested, including the laptop where it shows the channel as verified.

The list will update automatically and you shouldn’t have to delete the list file. Other users will be able to see that you channel is verified and be able to contribute to it.

Hey Mattches, thanks for following this up. Would you know when will be the next roll out of the update for the publisher list? I waited for couple of days since my last reply here, still the same result.

Can you please try hitting the Refresh status button for your channel in the Rewards panel (shown in the image I posted previously) and see if the status updates?

As I’ve shared previously, there is no Refresh Status button in the Rewards panel.


There would be if you navigate to your youtube channel first. The screenshot you posted looks like it was taken on your rewards page.

On my browser when I am on my own Brave reward page:


And on the same browser when I go to a page of an unverified creator:

1 Like

In my original post, I mentioned that from laptop A, logged in from my YT channel, I can see that my channel is already verified and the tip button is also available. No problem there.

However, in laptop B, posing as a subscriber, logged in to a different YT account, searched for my channel, there is where I have the problem, where I cannot see the tip button at all and no Refresh Status as well. What I can see is the Brave Rewards icon right beside the address bar doesnt have a check on it. And when I click on that icon, there is no tip button from the Reward Panel and neither a Refresh Status. Screenshot below.

Went to test on a third laptop, in laptop C (work laptop), same issue with laptop B.

Your channel is showing as verified when I look at it here, so there must be a local issue on your laptops B and C. It’s just a matter of finding out what it is.

Are B and C completely up to date with the latest version of Brave? On B or C, try setting up a fresh profile and then see if it works the way it should. Are you running any extensions on B or C? If so, try disabling them and see if it makes a difference.


Hey @klompje, thanks for the advise, that actually worked! I went and disabled all my extensions. Closed the browser. Opened a new session. And voila it worked! Now to find which extension is causing the issue. Are there any known extension/s that can cause this kind of problem?

Thanks for all the suggestions and help guys!


Glad to be of assistance. I have no idea which extensions cause this, but it is likely to be ad blockers, VPNs , etc. Anything that has access to your internet connection. It could even be that individual extensions pose no problem but together mess things up. It is a case of trial and error to find the culprit(s).

1 Like