No protection for saved passwords

After a long period of using Google Chrome, I migrated to the Brave.
I really love it and everything is fine, but there’s a BIG flaw for a browser that claims safety and privacy and that is it shows saved passwords without prompting any authentication. Maybe there’s an option which will fix this and I don’t know it. I’d be glad to get help about this awful issue.


What platform?

Shows passwords “where”, ie, in what context?

In Settings -> Passwords?

When you’re at a website login page?

For me, the password isn’t shown in either case.


I would also like to know the answer to all of these questions.


I’m using Brave on LinuxMint 20, and by shows passwords I meant in the Settings > Passwords.

1 Like

Are you saying that if you go to Settings --> Autofill --> Passwords, your passwords are shown immediately? Or that, when you elect to view them, you are not prompted to enter the auth. code/pass/pin for your OS?

The default behavior should be to request you re-enter your OS password in order to view any saved passwords in Brave.

Yes, exactly as you said.
There’s no password prompt, as opposed to default behavior.

1 Like

Can you try going to, on your Linux system, searching for the Passwords and keys Preference (that’s what it’s called in Ubuntu), then on the left-hand side, where it says Login – right-click the option and select Lock from the context menu.

Now open Brave, go to Autofill --> Passwords and try to view a password again in the same way – are you now prompted to enter your master password before viewing?

I did what you said.
Instead of prompting master password while seeing a password in Autofill --> Passwords, it will prompt it while opening the Brave.

1 Like

Just jumping in here because it seems like people in the thread know what they are talking about.
Hopefully I can ressurect the thread.

I have the same issue.
As I get to the settings - Password menu the passwords are anonimised. However, when clicking the “eye” icon they are displayed immediatly without being prompted to input the system admin password.

Differenlty from OP, I am on Windows 10, Brave version V1.18.78

I found my solution on widows.
Putting this here for future people looking for an answer.