No ads received since December

Are you able to receive general desktop/push notifications?

Are you in a supported region (if so, which one)?
Yes, U.S.

Give us a brief description of the ads behavior you’re seeing
I started using Brave in August, and received ads with no trouble until December. Since then, I’ve received maybe two ads total in almost two months. I’ve tried all of the trouble-shooting tips in the FAQ and in other posts, with no solution. According to @BraveSampson, at this moment there are 68 campaigns, 90 creative sets, 324 ads from 42 advertisers targeting United States, so there is no lack of ads to display. I have my Brave Rewards setting at 5 per hour and states turned off.

What OS/Brave version are you using?
Brave 1.19.88 Chromium: 88.0.4324.96 (Official Build) (64-bit)
Revision 68dba2d8a0b149a1d3afac56fa74648032bcf46b-refs/branch-heads/4324@{#1784}
OS Windows 7 Service Pack 1 (Build 7601)

@Mattches @steeven Can you help?

Hi @rosiecar - have you installed any new extensions since December?

@steeven Thanks for your reply! No, I have only two extensions installed: LastPass and StartPage. I installed both at the same time I installed Brave in August.

@steeven I just received a sponsored background image with the message that I would be paid for viewing it, but it’s still not registering in my “Estimated pending rewards”. And still no ads.

@Mattches @steeven Any update on this? Still not getting any notification ads, and the VERY few background ads I get aren’t credited to my pending rewards. As I said, I’ve already tried all of the trouble-shooting tips in the FAQ and gotten nowhere.

1 Like


  • Are you using a gaming mouse?
  • Is the browser running in full screen mode?
  • Do you have Focus assist enabled?
  • Can you tell me what region you’re located in?


  1. I am NOT using a gaming mouse. It is a basic 2-button USB wired mouse
  2. The browser is NOT running in full screen mode.
  3. As I mentioned in my OP, I am running Windows 7, which doesn’t have a Focus Assist and doesn’t appear to have any similar feature.
  4. As I mentioned in my OP, I am in the U.S. region.

Same here. Windows 7, low cost “gaming mouse” that doesn’t need a specific driver…

Today, I’ve reset my Brave Rewards from the History tab. The old BATs are lost as warned from this window, I’m seeing a new wallet number in “brave://rewards-internals/” URL (that’s why my old wallet is gone… but this is not the problem here ! )

So now, I hope the ads will come from Brave… (not sure because I’ve not seen any ad since 30 minutes…). Resetting the wallet looks like not helpful in this case :cry:

I had to switch from wifi to ethernet connection on my laptop the other day, and suddenly I started getting ads, for ONE DAY. Then, back to no ads, even though I’m still on ethernet. I didn’t make any other changes to my system.

@Mattches @steeven any ideas?

@rosiecar could you please let me know if the browser updated? And the version of the browser you are now running? Thanks

@petrus @rosiecar Would you be available for a Zoom call where we can share your screen and investigate why you are not receiving ads? If so, can you please email with available times so I can send an invite.

@tmancey I have updated the browser since my original post in this thread, but it has had no effect on receiving ads. I’m currently running Version 1.20.103 Chromium: 88.0.4324.152 (Official Build) (64-bit).

@rosiecar can you please DM me your locale. Thanks

Same, I just created another profile xD.-.

Nobody mentioned a firewall here, It could be the issue. I have my firewall activated and not a single ads is showing since I turned it on. At least that means the firewall is fully working.
I heard from many other users,having the same problem since around last December, no Ads showing, no firewall installed… probably the issue is with Brave Corp. and if it is do not expect an answer solution like. Just saying.

Have a good day everyone.

I’ve created a new profile + disabled proxy on my LAN (Privoxy)
1st ad since months is back…
But I did a mistake, I’ll try solution 1 by 1 :confused:

The issue turned out to be the VPN blocking the reloading of the catalog. The Brave team will be working on a permanent solution, but in the mean time, @tmancey and I figured out a workaround (Terry, correct me if I got the order wrong):

  1. Close Brave
  2. Turn off the VPN
  3. Reopen Brave and wait until you see a notification ad (approximately five minutes)
  4. Turn the VPN back on

This allows Brave to reload the catalog with approximately a day’s worth of ads. This process will have to be done daily in order to keep the ads flowing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.