Newly updated Brave 1.7.98 Chromium 81.0.4044.113 unresponsive for 3-min after launch

Today Brave Browser updated itself from the previous Chromium 80.x version to Brave 1.7.98 Chromium 81.0.4044.113 (Official Build) (64-bit). This is on a Win10 x64 Pro 1909 PC, with latest Windows Updates.

The program was working fine before this update. I will note that Brave has always taken “a little while” to start even on this fast PC (Intel Core i9, 32G-DDR4, NVMe SSD, GeForce RTX2080) – from the time the GUI screen is up, it still would take 5-sec or more for it to respond to my mouse or let me type. I’m not doing anything odd (e.g. VPN) for Internet access, nor using Brave Sync.

But this new Brave version is off the deep end. After I start, Brave is completely unresponsive for a long while. After launch the GUI appears (with bookmark icons & URL bar) but the Task Manager says Brave (and its dozen sub-tasks) usage is “very high” which equates to about 10% of the CPU. It takes about 3-min before it finally allows me to do anything (respond to the mouse by launching a bookmark or dropping a menu, or letting me type in the URL bar) after which the program is then responsive. At that point the TM usage is “very low,” i.e about 0.1%. I’ve also Disabled all extensions, no diff.

During the non-responsive period, I’m unable to access Brave’s “hamburger”/More tools/Task Manager to figure out which Brave task is running at a high value. By the time Brave gives me control to do that, the high usage has subsided.

Initially some sites wouldn’t work – e.g. Netflix would tell me that “something had gone wrong” and not let me access anything. I finally cleared the history/browser catch (Browsing history, download history, Cookies and other site data, Cached images and files) then restarted. After the 3-min wait (unchanged) for Brave startup, Netflix and a few other sites that didn’t work were OK after I relogged in. I’ve also been slowly turning on some of my extensions (e.g. password manager) although that hasn’t made a diff.

Launching from a CLI (brave.exe --disable-gpu) doesn’t make any diff.

So right now I’m left with “Brave is unresponsive for about 3-min after launch” although everything else I’ve tried seems to work OK after that. For now I’ll just try not to quit the program, and hope that a future update fixes this.

I’ll also mention that Chrome doesn’t have this problem.
Chrome: 81.0.4044.113 (Official Build) (64-bit), and now 81.0.4044.122 (Official Build) (64-bit).

5 Likes

I’m having the same problem on Windows 10 Home 64-bit 1809 (Build 17763.1098).

Same exact thing. It started happening after updating to latest version.

Received message that there’s a new update. So I restarted Brave and after that, I’m not able to use Brave anymore.

Every time I open it, it just freeze there. Windows 10 Task Manager shows high CPU usage from Brave.

I’ve tried uninstalling and reinstalling (without deleting browsing data), tried using --disable-brave-sync and --disable-extensions, but it doesn’t solve the problem.

2 Likes

@WayOutWest

I’ve opened an issue on github: https://github.com/brave/brave-browser/issues/9372

1 Like

I’m having the same problem - very slow

2 Likes

On github the developers asked me to test running Brave with --disable-gpu, but it doesn’t make any difference. You should give it a try, maybe it will work on your system.

1 Like

I tried it as well and it the difference is marginally better. Still very slow.

2 Likes

Ok i am facing the same problem, it is rather weird. Tried the --disabled-gpu thingy but it is still laggy and unmanageable.

In order to keep using the browser, i downloaded the beta version and it seems to work ok. No bookmarks syncing etc but at least it helps up until the devs ll figure out what is going on!

1 Like

Same issue here. CPU usage was high, i thought a bad extension was the cause.

2 Likes

Does anyone know how to transfer user profile and browsing data from Brave release channel to Brave Beta? Is it possible?

I can’t answer your question but I find it very interesting that you are experiencing exactly the same problem as me and I’m using an Android device! So, the problem is cross-platform?

spinon

2 Likes

Probably, here’s another unlucky user on MacOS

1 Like

Ah, that being the case, it suggests to me that the problem lies at the Brave end or in the transfer of data between server(s) and clients. Does that make sense?

spinon

1 Like

I would suggest using the --disabled-gpu way in the shortcut of the stable release and then export your bookmarks etc. Then you are able to load them into the Beta! Although pass and user accounts do not transfer

1 Like

Thanks. Unfortunately the --disable-gpu way doesn’t work for me, the browser still freezes.

I already had my bookmark backup, what I’m worried about is extensions. It’s gonna be a chore having to reinstall and configure them one by one.

2 Likes

My Brave browser also suffers from the same issue after updating to the same version as the OP. It freezes for several minutes on launch with high CPU usage before it can be used. It only started happening today. I’m running Windows 10 Home (17763.1158)

2 Likes

I am also having the same issue. It freezes for several minutes on launch with high CPU usage before it can be used. Once it is working I am able to open new tabs and the performance is OK.

My work around it to leave Brave running all the time.

I am using Windows 10 Pro Version 1909 OS Build 18363.815

2 Likes

Same problem here! My Brave browser (v1.7.98; Chromium: 81.0.4044.113 (Official Build) (64-bit)) freezes for 20 seconds after starting it.

I’m using Windows 10 Home 1909 b18363.815.

2 Likes

I’m having the same issue on MacOS (10.14.6), so this isn’t strictly a Windows issue.

2 Likes

For those folks experiencing the above issues, could you launch Brave via the terminal/CLI via the following:

macOS

--args --log-level=2 --enable-logging=stderr

Example of how how to use the above on command:

/Applications/Brave\ Browser.app/Contents/MacOS/Brave\ Browser --args --log-level=2 --enable-logging=stderr

Leave Brave running for a bit and once you’ve hit the issue, copy/paste the output into a text file and please email kamil@brave.com.

Windows

  • Right click on the Brave shortcut and select Properties
  • Add --enable-logging --log-level=2 to the end of Target, example:

“C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe” --enable-logging --log-level=2

  • Click on Apply (might need to accept as Administrator)
  • Run Brave via the shortcut (might see a CMD terminal appear)
  • Once you’re run into the issue, send over the following log dump to kamil@brave.com

C:\Users\kamil\AppData\Local\BraveSoftware\Brave-Browser\User Data\chrome_debug.log

Hopefully it will give us a smoking gun of what’s occurring so we can release a fix ASAP.

3 Likes

I’m not using Brave Rewards, nor have I ever set up nor interacted with a “wallet.”

[C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application]brave.exe --args --log-level=2 --enable-logging=stderr

[C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application][9192:11976:0423/183127.149:ERROR:browser_switcher_service.cc(238)] XXX Init()
[5992:6300:0423/183127.163:INFO:confirmations_impl.cc(61)] Initializing confirmations
[5992:6300:0423/183127.163:INFO:confirmations_impl.cc(763)] Loading confirmations state
[5992:6300:0423/183128.837:INFO:confirmations_impl.cc(782)] Successfully loaded confirmations state
[5992:6300:0423/183128.838:INFO:confirmations_impl.cc(743)] Saving confirmations state
[5992:6300:0423/183128.838:INFO:confirmations_impl.cc(743)] Saving confirmations state
[5992:6300:0423/183128.838:INFO:confirmations_impl.cc(743)] Saving confirmations state
[5992:6300:0423/183128.876:INFO:confirmations_impl.cc(759)] Successfully saved confirmations state
[5992:6300:0423/183128.884:INFO:confirmations_impl.cc(759)] Successfully saved confirmations state
[5992:6300:0423/183128.887:INFO:confirmations_impl.cc(759)] Successfully saved confirmations state
[9192:11716:0423/183128.901:ERROR:rewards_service_impl.cc(193)] Failed to read file:
C:\Users\MyUserID\AppData\Local\BraveSoftware\Brave-Browser\User Data\Default\ledger_state
[5992:6300:0423/183128.911:ERROR:ledger_impl.cc(113)] Failed to initialize wallet