New Tabs Still Open In Mobile View & Related Gesture Bug

Continuing the discussion from 1.5.120 does not open new tabs in desktop mode:

It’s been more than a year now since this bug turned up. The fix seems relatively simple but no one is assigned to it. It’s still incredibly annoying to have to edit “m.” out of the URL of every site opened externally or in a new tab because it uses an incorrect user agent on the first page load.

A little additional info I’ve just discovered that makes this even more cumbersome:

Tabs opened in mobile view disable gestures (swipe on the sides for back/close and forward) for some reason. So since every page opened in a new tab uses the mobile view because of this bug gestures also get disabled and you can’t swipe to the right to close a newly opened tab.

@Wiggly,
For the mobile view issue, I’ve pinged some of the devs in that thread to hopefully get some attention on the issue.

As for the gestures, I seem to be able to use gestures without issue for the mobile and desktop versions of sites. Are you using the most up to date version of the browser at this time?

@Mattches

I’m using 1.24.85. So far the mobile view gesture disappearance issue seems to be exclusive to Reddit.

@Wiggly,
Ah I see – so swipe gestures do work for other sites just not reddit? Also it looks like we got the issue submitted bumped to P2 priority which is good – should get a fix soon.

1 Like

@Mattches

Awesome! Glad to hear it.

As for the gesture issue, it appears so, yes. Reddit is the first and only place I noticed the behavior but I’ll report back if I find any other affected sites.

1 Like

@Wiggly,
Thank you for letting us know. I’ll keep this thread open for now in case there are any updates.