New Tabs Always Open In Mobile View Until Brave Is Relaunched

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.


Description of the issue:
For some reason despite having my settings set to use desktop view as the default, if I long press on something and open it in a new tab, when I switch to that new tab the page will be in mobile view. The only exception to this is websites that do not have a mobile version. The “desktop site” option will be checked and active, but the page in the new tab will display the mobile version of that site, so the setting is working somewhat in the sense that the “desktop site” box is checked.

Now here’s the weird part. If I press the home button and reenter Brave then the mobile view will vanish and the site will, without reloading, reformat itself into the proper desktop view format. The same result is achieved by moving into the app switcher and then reentering Brave without exiting to the home screen. However doing this will only reformat that one tab. As soon as I swipe to the next tab it will display in mobile format, which again requires me to exit and reenter the browser so that the page switches to the desktop view. In other words exiting and reentering only fixes the active tab, and it has to be done on every single new tab opened. Switching back to a tab that had already been “fixed” by exiting and reentering does not return it to the mobile display (thankfully).

How can this issue be reproduced?

  1. With desktop view enabled as default in settings, long press any link and open it in a new tab.
  2. Switch to that tab. Despite the settings it will be in mobile display mode.
  3. To fix it leave the browser and reenter it either via the home button or the app switcher. This has to be done on every single new tab opened via long pressing a link.

Expected result:
The page opened in the new tab should be in desktop view without having to leave and reenter the browser.

Brave Version( check About Brave):
Android 8.0.0 Oreo, Brave version 1.5.6 Chromium 80.0.3987.99
It’s been a problem for months now.

Mobile Device details
Samsung Galaxy S8+ Android 8.0.0 Oreo.

Additional Information:
I can create a recording of this behavior if you’d like. It’s extremely easy to reproduce.

I can’t upload attachments because I’m a new user, so here’s an embedded recording of this issue uploaded elsewhere instead.

This issue is still present on the 1.8.7 chromium 80.0.3987.119 update.

Edit: This issue is also present on the Samsung Galaxy S10+ running Android 10.

Edit 2: The issue persists on Brave 1.5.8.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.