New Brave wallet and MetaMask do not work with dapps

After the release of the new Brave wallet, MetaMask stopped working (Still works in all other browsers) with Ethereum dapps. Also, the new Brave wallet doesn’t work as well. The only thing that works is using the deprecated Brave crypto wallet.

Is there any documentation on the new Brave wallet? (can’t seem to find any).

Why is there no longer an option to use MetaMask as default wallet?

How do I get either to work? I need at the very least to have MetaMask working again since the old crypto wallet is marked as deprecated.

1 Like

You can still use MM by setting Default Crypto Wallet to Brave Wallet (Prefer Extensions)

Can you elaborate what is not working?

I face the same issues with the Brave Wallet (Prefer Extensions) settings. I’m not sure what the issue is, but with either new brave wallet or metamask (with Prefer Extensions setting), when accessing a web3 dapp, it’s as if the wallet doesn’t exist, it’s not detected.

Metamask of course still works in other browsers, and the depricated brave crypto wallet still works in brave. If the new wallet doesn’t work then I’d rather use metamask over the deprecated, but dapps don’t detect either.

1 Like

I’m having issues with staking in some dapps

I just shut off Brave wallet under extension settings and my metamask started working again

There is no other option for other wallet extensions to work when the brave wallet is on. You now have to shut off the Brave wallet to get Metamask to work.

You should be able to select the Brave Wallet prefer extensions option in settings://wallet to continue using MM while still having Wallet enabled.

Can you please tell me what specific dapp you were trying to use when you encountered this issue?

Once I shut the brave wallet off the Dapp connected to Metamask

Have you tried the Brave Wallet prefer extensions option?

that’s what is was set to and it didn’t work

I won’t use brave wallet until it get’s fixed. Also the Bat token rewards need to be able to move to other wallets than Gemini or Lynqtu

I connected my ledger to brave and it wouldn’t give that as an option either

Here is another Dapp it would not connect to:
You must have the Canary network set up on metamask to use it.

Thank you for the information – I’m passing it along to the team presently.

1 Like

I’m having the same issue as well with the new brave wallet update on

Before the update, my wallet connected just fine and now it won’t connect or even give me the option to connect a new wallet through the dapps.

No metamask wallet involved here, just the brave browser wallet after update issues.

@WaXy @Dapp,
Does setting the option to None allow MM to work?

I did some testing and found the reason MetaMask wasn’t connecting is because the dapp was using the deprecated ethereum.enable(). I ran a test in the console with eth_requestAccounts and MetaMask then prompts to connect, this is with prefer extensions setting enabled.

However, with the new brave wallet window.ethereum is always undefined, so the dapp can’t connect because there is no provider.

These connectivity issues will be fixed in 1.32.x HF which will be released most likely on 23rd.

Metamask supports both ethereum.enable and eth_requestAccounts. With Brave wallet, window.ethereum should only be undefined when the default wallet setting (Settings --> Wallet) is set to None.