Netflix spins - does not play

From the Netflix “Browse” screen, I can watch, and hear, the promoted video and can select any other video I care to watch. Selecting a new video, or restarting a partially watched video results in a single still frame and a red spinning circle in the middle of the screen. The circle will spin “forever.” That screen / overlay can be dismissed (X in the upper right) but does not respond to any other mouse or keyboard actions.

I started with a total reset of Brave. New user profile. Only 1 extension active (LastPass).
Settings are all default, after a reset.
I have not changed site settings for Netflix, they’re still default.
Brave is version 0.66.101. Running on Windows 10 / 1903. Widevine was installed at first use of Netflix and says it is up to date, 4.10.1440.18.

The problem persists with shields up or shields down.
From other trouble reports, I tried with and without H/W acceleration. No difference.

What should I try next?

THANKS for any advice.
BTW, Netflix works as expected on real Chrome, and on Vivaldi on this system.

@bobeaston,
Thanks for reaching out – and excellent report!
Can you try clicking the “lock” icon in the address bar, then Site Settings --> Clear data and see if this helps the issue?

Thanks for the suggestion Mattches. That action makes no difference.

Next?

1 Like

@bobeaston,
Very strange. On my end, Netflix seems to be working just fine. I even went ahead and un/reinstalled the Brave (release), installed Last pass and left everything else as default to mimic your setup – Netflix still works like a charm.

I’m wondering if you could try and see if any other video streaming sites exhibit the same behavior? It would help to know/confirm that it’s only Netflix that has this issue.

Other streaming services, such as YouTube and Vimeo work just fine.
Videos embedded in many news sites work well too.

DirecTVNow fails in a way similar to NetFlix. I can sign in, see the full grid of programs and select any of them. Yet when the stream arrives it throws an error. BTW, this is with shields down and site settings changed to allow ads.

As much as I like Brave, I´m headed back to Vivaldi. Thanks for your help.

@bobeaston,
What about sites like Hulu/Amazon video?

The fix for the issue you’re encountering is likely simply/quick but we need to rule out all possibilities. If I’m able to install a fresh build of Brave with a setup that mimics yours (roughly) and view Netflix content, you should be able to as well.

Additionally, you could take a quick screen capture of the dev tools console window, which will help us see whats going on in the background:

  1. Visit Netflix.com
  2. Menu --> More tools --> Dev Tools --> [Console]
  3. Attempt to stream a video and screencap any output in the console and leave it in your reply.

Thanks again Mattches.
I don’t have either a Hulu or Amazon subscription.

However…
I just installed Brave on a laptop that has never had Brave on it. Netflix works right “outta the box.” Directvnow also works, after lowering shields.

I’ll try again on the original system (probably tomorrow) with complete removal and reinstall.

Thanks again for your persistence.

1 Like

Success on the original system… Here’s what I did…

  1. I used Windows 10 Apps control panel to remove the existing Brave browser.
  2. Then, I followed up by chasing down and removing AppData folders. More on that in a moment.
  3. Did a clean install from a new download.
  4. Tried Netflix. It worked with no setting changes at all.
  5. Tried DirecTVNow. It too worked, after setting allow autoplay and dropping shields.

Now, about AppData. I found and deleted a “BraveSoftware” folder in AppData/Local. There was also a “Brave” folder there from a long-ago-removed version of the original Brave browser. I deleted it too. In AppData/Roaming I found another “Brave” (original) folder and deleted it.

An aside. As part of yesterday’s diagnostic actions, I renamed the Brave Browser’s AppData “default” (user profile files) to “backup-default” and let Brave build a new user profile.

Speculation… Could it be that some of the older, unremoved, “Brave” data was being used by the newer Brave Browser? … Or, was yesterday’s instance of the browser still using some data from that original “default” user profile.

Either way, I am considering the problem resolved … and am mildly disagreeable about applications that don’t remove all of their AppData when the application is removed from the system. Yes, I understand that leaving that data in place makes a re-install easier. But, it can also perpetuate a nagging problem.

Thanks Mattches for your persistence.

1 Like

@bobeaston,
My pleasure – but it was really all you!

:point_up: Short answer is yes, we’ve had previous issues with profile data from one installation interfering with the other – but only between the new Brave (core) builds and old ones (Muon). I find it very strange that that is the way the issue chose to manifest, as it was overall quite innocuous.

Thank you for your patience, bob. Enjoy your privacy and please feel free to tag me should you return with another issue.

I’m glad @bobeaston was able to work out the issue on his system. Interestingly enough, I also discovered Netflix not working last night and have never had Muon on this machine. I was using macOS 10.14.5 and Brave Version 0.70.12 Chromium: 76.0.3809.72 (Official Build) nightly (64-bit). I was too tired to monkey with it beyond trying and sleepily failing to find Widevine install information last night so I used Safari to get my fix. However, I just tried it again with the same result, but I also tried Release 66.101 and that worked with no changes. Here’s what I got trying it just now in Nightly, shields off and DD2’s extension off:

Again, Release worked fine.

So, I tried logging out of Netflix in Nightly (shields down, DD2 off), and it played the first thing I tried, then barfed with the same error on something else. Signed out and in again, no dice at all. Tried a vanilla profile, same result. Created a new profile, same result.

Then I tried Amazon Prime Video and got this:


Here’s what Console shows:
image
Turned shields and DD2 off for Amazon Prime and Console shows this (same error spewed):
image

So I guess somehow I borked my Widevine install for Nightly or something else is wrong.

I tried actually following the Amazon instructions and found this:
image

then I clicked the Check for update button and got this:
image

So apparently it’s installed and updated, but not working.

Also checked brave://settings/content/protectedContent, and it’s set to play protected content.

@hnktong,
Thank you for the info – very helpful. Testing on my end right now and will report back what I find.

Yeah – got the same result.
Looks like this is already known and being addressed though.

Issue:

Pull request:

1 Like