Netflix on Brave under Linux

Description of the issue:

Even after enabling Widevine, Netflix doesn’t play under Linux Brave even with the “shields” down… The main Netflix menu comes up, clicking on a content tile brings up the controls and the title information, some data seems to be pre-fetched, but then it freezes. Clicking the Start triangle has no effect. It does this on two of my computers, so it’s not related to just one of them, and Netflix works fine on Firefox but fails the same way on vanilla Chrome.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Go to netflix.com
  2. Sign in
  3. Some preview audio/video may start
  4. Pick something and click it.

Actual Result (gifs and screenshots are welcome!):

Screen goes black but video controls show up if you mouse over it. Progress bar red dot sticks at zero but progress pre-load indicator shows some preloading, but the Start button has no effect. Volume controls etc respond to the mouse.

Expected result:

Video should play.

Reproduces how often:

Every time.

Operating System and Brave Version(See the About Brave page in the main menu):

Linux 5.14.18-100.fc33.x86_64 #1 SMP Fri Nov 12 17:38:44 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Brave Version 1.32.115 Chromium: 96.0.4664.93 (Official Build) (64-bit)

Additional Information:

HTML5 Disable Autoplay extension installed but deactivated. Youtube, Curiositystream, news site videos, etc, all work.

1 Like

@ChrisMoller,
Can you visit Netflix, attempt to play a video and, upon failure, open the dev tools console window (Menu --> More tools --> Dev tools --> [Console] ) and share any output here? A screenshot of the console window will be just fine.

1 Like

Guessing here,

  • Possibly disabling Hardware acceleration via brave://settings/system then retesting.

  • Or possibly disabling, and then re-enabling widevine in brave://settings/extensions

Thanks for the reply.

The devtools console tab contains:

NETFLEX ERROR: Stored configuration value for variable highlightSubtitles is not valid, default value was used instead.

I tried turning subtitles off, but that didn’t help.

Now it says:

crbug/1173575, non-JS module files deprecated.
3
global.js:2415 NETFLEX ERROR: Stored configuration value for variable highlightSubtitles is not valid, default value was used instead.
VM2103:6772 crbug/1173575, non-JS module files deprecated.
(anonymous) @ VM2103:6772
DevTools failed to load source map: Could not load content for chrome-extension://gjcgfkhgpaccjpjokgpekpgpphgaanej/libs/dompurify/purify.min.js.map: HTTP error: status code 404, net::ERR_UNKNOWN_URL_SCHEME


Are you using an extension? https://chrome.google.com/webstore/detail/netflix-extended/gjcgfkhgpaccjpjokgpekpgpphgaanej?hl=en ? Try disabling this extension.

2 Likes

No, I wasn’t using that extension–but your suggestion inspired me to check what other extensions I was running and disabling “Disable HTML5 Autoplay” got Netflix to work.

Thanks for the help.

2 Likes