Netflix Not Working Anymore

hey all, I’m having some problems with Netflix. I’m using Brave on MacOS Mojave and Netflix has stopped working. It’s been working fine since I installed Brave a few months ago, but now I get the error code M7034 (network connectivity issues) whenever I try to play a video. I’ve tried running Netflix in other browsers and it’s worked successfully, so I know that the problem has to be with Brave.

Anyone have some guidance on this? Netflix has just totally stopped working altogether when I try to play a video.

Thanks for reaching out.
While testing on my end, I can visit and navigate Netflix just fine as well as stream content. I’m also using a macOS with the latest Brave release.

Can you try turning Shields down and streaming from Netflix? If this doesn’t work, please let me know and we will continue troubleshooting. If it does work, try turning Shields back up and see if video playback initiates or if it throws an error again.

I’ve turned down Shields, but it still doesn’t work. Any other advice?


Oh yeah – we’ll get this fixed. Next I’d like to try clearing site data for Netflix. Please try the following:

  1. In Brave, visit Netflix and click on the “lock” icon image|26x18| on the left side of the address bar
  2. Then, Site Settings and select both Clear data and Reset Permissions
  3. Relaunch the browser

Now try to visit Netflix and stream again. Let me know what happens.

Use Chrome w/ad-block. My Amazon Prime video streaming service doesn’t work in Brave but it’s fine in Chrome… I have both Chrome and Brave installed.

Hmm. I tried @Mattches’ suggestions, but nothing changed.

Hi, have you tried the official Netflix solution yet?

To clarify: I have tried the official Netflix solution, but I don’t think that the error code is accurate - Netflix works on my other browsers, so I don’t think it’s a network issue.

Netflix works on my other browsers

Sorry, I missed that.

Windows 10 laptop, high end graphics card, updated. Every thing, even Windows 10 completely updated.

My Netflix freezes every few minutes and will not restart unless I back it 10 seconds or forward. My shields are off, I have cleared cookies and reset permissions as suggested above.
I spent 2 hours with Netflix, not the front person, but the techs that call you and do a screen share.

I have turned off/on my laptop till I am blue, constantly clear cookies, etc… No answer and the tech person had no answers other than Brave not supported.

Netflix works on Chrome and Edge just fine.

Any other suggestions?

Top Hat

I would try disabling Hardware Acceleration – this smells like a HWA issue.

Settings --> Advanced --> System --> Hardware Acceleration

Let me know if this improves playback on your end.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.