Multiple Office365 Sites won't load in Brave on Win10

bug

#1

When using my companies O365 account in Brave on Windows 10, I am able to access some of the Microsoft web-apps (Planner, Word), and cannot access others (Sharepoint, OneNote, OneDrive).

Pertinent points:

  • I am definitely logged into my O365 account at all times
  • I have tried reducing multiple levels of Brave protection, ultimately turning off Shields completely for these sites.
  • When logging into Sharepoint, it appears to be getting caught in a loop between the microsoft authentication screen and sharepoint page itself. I compared this with Google Chrome and it’s definitely this loop that Brave is getting caught in.
  • When logging into OneNote, I get the error message in the screenshot supplied below.
  • currently on Windows 10, Brave Version 0.58.18 Chromium: 71.0.3578.98 (Official Build) (64-bit)

Please help! I love Brave and want to keep using it!!

Annotation%202019-01-03%20154312

Reproduces how often:

Brave Version(about:brave):

Reproducible on current live release (yes/no):

Additional Information:


#2

Hmm, this is strange. I’m able to login and use all MSO365 web apps without any issues. I’m a bit surprised myself actually - Shields blocked a ton of stuff and I was sure something was going to break.

Try the following:

  1. Visit Office365
  2. Click the padlock on the left-hand side of the address bar and select Site Settings
  3. At the very bottom, select Reset site permissions, which will do exactly what it sounds like
  4. Set both your Default Shields settings (in Main menu --> Settings -->Shields defaults) and the Shields panel (while on office365) to their original settings. They should look like this:

Close and reopen Brave (just to be safe) and try to login and use Office365 apps again. Let me know what you find out.


#3

Morning Mattches,

Thanks for getting back to me!

I followed your instructions, and am still getting the exact same issue. Interesting thing I’ve just noticed – I’m getting two distinct behaviours, based on which O365 product I try and access:

  1. Sharepoint + OneDrive + Outlook: I’m getting the same looping behaviour. FYI the page that Brave appears to be getting hung up on and looping over is at this URL:

https://login.microsoftonline.com/289a31fd-7bf0-4fb7-9a8d-62e687712639/oauth2/authorize?client_id=00000003-0000-0ff1-ce00-000000000000&response_mode=form_post&response_type=code%20id_token&resource=00000003-0000-0ff1-ce00-000000000000&scope=openid&nonce=0E763F9E0200A4D493A750793494BE01ECB257E2BCCE4BF9-D901CD8E1093ED3F0F138FC0821A9DA131E784A583052824164FBF0F85DA38C8&redirect_uri=https:%2F%2Fredeyeapps.sharepoint.com%2F_forms%2Fdefault.aspx&wsucxt=1&cobrandid=11bd8083-87e0-41b5-bb78-0bc43c8a8e8a&client-request-id=42c0b29e-6021-7000-a9eb-cbda192eca63

  1. OneNote: it’s taking me directly to the OneNote main product page (via this URL: https://www.onenote.com/signin?wdorigin=ondc), and then when I attempt to login I’m getting the same error message that I originally shared (below).

Any advice would be greatly appreciated!

Cheers, DS


#4

I’ve got an issue logged right now with that describes Shields settings not being respected when set. I believe this may be what you’re encountering. The issue is logged here:

Unfortunately I don’t have a workaround for you at the moment. There’s two things you can try:

  1. Try launching a Private Window and attempting to authenticate into Office again

  2. You can try downloading the Beta or Developer channel Brave release and see if you can access the site using one of those. Each release channel will be installed separately and won’t overwrite or delete any of your previous browsing data.


closed #5

This topic was automatically closed after 30 days. New replies are no longer allowed.