Inconsistent O365 Teams Support

Description of the issue: I have Brave running on two Macs - on one, I’m able to log into Teams and chat/videoconf/audioconf/screenshare, but on the other, I get the “unsupported Browser” screen and am never able to log in.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Go to
  2. Log in with my org credentials
  3. From the app selection menu, choose “Teams”
  4. Get redirected to the “Unsupported browser” screen.

Actual Result (gifs and screenshots are welcome!):

– Actual result: redirected to “Unsupported Browser Screen”

Expected result:
– Expected result - Teams loads

Reproduces how often:
Every time I try to load O365 Teams from the affected machine.

Operating System and Brave Version(See the About Brave page in the main menu):
Brave version 1.13.82
MacOS 10.15.6

Additional Information:
Fingerprinting protection set to standard.
Shields down for * and *

Can you try clearing cache/site data for Office365 in the browser on the device that throws the error by going to O365, clicking the “lock” icon in the address bar, then Site settings --> clear data. Make sure you refresh the page after doing this.

Then, authenticate again and see if you still get the same error.

1 Like

On the machine with the error - I navigated to O365, clicked the lock > site settings > clear data in both O365 and repeated the process with Teams; relaunch browser and authenticate, and get the same error.

@bravtian Tested this, only worked with Allow all Cookies in Shields. Can you confirm?

Shields are down for and, so I don’t have the ability to change the setting to Allow all Cookies. Even wish shields disabled, I still get the “Unsupported browser” splash screen when trying to load teams.

You can turn Shields = Up at any time by clicking the lion icon in the address bar. Visit Office 365 and turn Shields on, then change the cookie control option to Allow all cookies as @fanboynz suggests.

My testing with and Brave.

I wasn’t able to login to teams with default sheilds (due to cookies)

On your suggestions and following the example from fanboynz, I turned shields on to allow me to set fingerprinting/cookie/tracker access to be the most permissive and tried again - teams still would not load with either shields on or off.

Are there other settings I should be looking at?

I did a screen record as well - but my account is too new to upload attachments, so I attached it at this oneDrive link.!AlAVU6zDvAr_iVVnXg9V-j3IxltW?e=oG8MXP

If you Allow all Cookies Globally in brave://settings, does it help? @bravtian

Unfortunately… Allow All Cookies doesn’t do anything for me.

That said - it does look like some sort of cookie problem - Teams loads for me when I use a private session…I wish I could use a normal session, but at least I have a short term solution. Hopefully whatever the underlying cause is addressed in a future build of O365 or Brave…

Thanks for all the help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.