Mobile bookmarks not showing up on desktop

Apologies if I’m just new and unfamiliar with how this should work, but on the current version (1.44.112), my mobile bookmarks don’t seem to be syncing to my desktop. There isn’t a “Mobile Bookmarks” folder anywhere in brave://bookmarks/, and sync is definitely enabled on both devices. What gives?

Thanks for reaching out.
There are a few things that could be happening here but to start, can you confirm that both devices are own the same sync chain and not on their own individual chains? To check this, on your desktop, go to Settings —> Sync --> Managed Sync devices. Here you should see devices listed on your chain — do you see your Android device listed here (you can see my Android device listed at the top in the image below):

My bad, I should have mentioned that detail. Yes, they’re on the same sync chain.

Have you enabled bookmark sync?

Yes, I’ve tried both the “sync everything” option as well as customized sync with all the options enabled.

Could you disconnect from the chain and join it again ?
Also try starting a new sync chain.

Sorry, that didn’t work either.

Okay, so the “Mobile bookmarks” folder did finally show up, but with only some of the bookmarks. Really odd.

Sometimes it can take a bit for everything to fully Sync — are you still missing bookmarks from your mobile device?

Update, the “Mobile bookmarks” folder (which only showed a small portion of what it should’ve on desktop) is now gone again. I have no idea what else I can do, starting a new sync chain does not work.

You can check in detail stuff about the sync chain by using brave://sync-internals then you can see if it is synching correctly, if it is showing the correct amount of bookmarks in the main page.
And Also you can use the Sync Node Browser tab to see exactly what is being synched. Both Android and Desktop should have access to the Sync-Internals, so make sure you can check that on both.

Since this is about bookmarks, I would check the bookmarks file on desktop and see if it is a bug in he UI or the file itself, or export the bookmarks and see what it says since it is easier to read the HTML file.

Also, Is your Auto Sync Data on in your Android?

Sync v2 on Android respects the system-wide option “Automatically sync data”, so if you found that Brave Sync v2 does not work on your Android device, you should ensure that system option is in the position on. The location of that option depends on device manufacturer, but you may find it in:

  • System settings --> Accounts --> Automatically Sync Data
  • System settings --> Accounts and backup --> Accounts --> Auto Sync Data
  • System settings --> Cloud and accounts --> Accounts --> Auto Sync Data

In order to sync v2 work on Android it is required to turn that option on.

The “Automatically sync data” option is on.

In brave://sync-internals/ under “Status from Last Completed Session” it says:


in red text. Could this be causing the issue? How do I fix it?

In brave://sync-internals/ under “Status from Last Completed Session” it says:
in red text. Could this be causing the issue? How do I fix it?

Thanks for the report.

Yes, SERVER_RETURN_TRANSIENT_ERROR is the reason why sync doesn’t work properly.

This means that the client cannot push the changes to the server. Sync polling interval is increased to 10 minutes. And sync doesn’t work as expected.
It can happen by different reasons.

Could you please now open brave://sync-internals/ page, Traffic Log tab and scroll down to the latest Commit Response record with the TRANSIENT ERROR code, it must have more details which will help us to find the failure reason and hopefully fix it.

As a workaround, these steps usually help with such error:

  1. Open brave://settings/braveSync/setup
  2. Turn all Sync data types off
  3. Exit browser, start browser
  4. At the brave://settings/braveSync/setup page turn on the required data types.

this will trigger client to re-fetch all the data from the server and must help.

The workaround does work, but I have to do it for every session.

The Commit Response does say Result: SYNCER_OK but when opened it says: "commit": { "entryresponse": [ { "error_message": "There are already 50000 non-deleted objects in store", "response_type": "OVER_QUOTA" }, over and over again.

Hello @SthVidya,

We are looking for the reason of this.

Do you know, how many objects approximately do you have to be synced? In other words, the number of bookmarks, history entries, or passwords? Does you browser have enormous count of any of these?