Media buttons not working on snap version of Brave

Media buttons (play, pause on keyboard) don’t work on the snap version of Brave.

Whenever I’m playing a stream (ie. Youtube, Spotify, etc) and press “play/pause” on my keyboard, it doesn’t pause the video or song.

This bug only happens on the snap version of Brave, the Debian package works fine.

Lack of media-control interface. Running snap connections brave doesn’t show media-control which is necessary to access the keyboard’s media keys.

Version info:
OS: Ubuntu 22.04
Brave Version 1.37.116 Chromium: 100.0.4896.127 (Official Build) (64-bit)

1 Like

I’m not a snap developer, but I believe the solution is to simply add media-controls to the snapcraft.yaml

Status update: Still not working on the latest version (Apr 27, 2022):

  • Version 1.38.109 Chromium: 101.0.4951.41 (Official Build) (64-bit)

PS: As this is the top result on Google for this issue, I will try to keep posting updates here on the status (working or not). It may be helpful for anyone experiencing the same issue.

There are numerous topics recently posted about the brave://flag #hardware-media-key-handling no longer being available. Workaround posted below. Is this the same or related issue?

Search for a flag called #temporary-unexpire-flags-m100 , enable it and relaunch the browser, then search for #hardware-media-key-handling and the flag should appear.

1 Like

Thanks for the reply. Unfortunately, it didn’t work.

I tried #hardware-media-key-handling enabled and disabled (re-launched Brave and re-booted my Ubuntu after each change, just in case).

This same issue happens with the snap versions of Firefox and Chrome too. And it used to happen with Spotify (snap version), but they fixed the problem.

So, I’m sure it is something related to the snap packaging.

I just found these two open bugs that are the same problem I’m having:

1 Like

Ouch, those are old with no movement… :slightly_frowning_face:

Did you follow the link in the first issue report? Was wondering if that gave you any additional information to help you solve problem.

There is a thread from 2020 on the snap forums discussing this issue for Firefox, with eventual resolution.

1 Like

Thanks, I can easily fix this issue on my end, I just have to use the deb version of Brave.

The media keys not working is not a bug that prevents Brave usage on Ubuntu. But as Brave officially supports snap, and this is a bug on the snap package, it is good to report.

I also think it is helpful for Ubuntu users to know the status of this bug when they google it. So they know their choices are to not use the official snap package, or to not use media keys.

1 Like

Status update: Still not working on the latest version (Jun 28, 2022):

  • Version 1.39.122 Chromium: 102.0.5005.115 (Official Build) (64-bit)

The latest version of Brave for desktop on the Release Notes category is 1.40.107. On Brave GitHub the Changelog latest version is 1.40.109, so a new update is probably going to be released shortly. You might want to upgrade and see if you are still experiencing the problem.

Official Brave website:
Linux installation instructions

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.