Media Keys not working, tried everything in my knowledge already

Description of the issue:
Keyboard media keys not working on sites like YouTube, Spotify, SoundCloud, etc.

Things I tried already:
I know that there is the Brave flag about Hardware Media Key Handling, disabling it didn’t fix it either.
I also tried following this guide from roughly a year ago as well and created a completely new profile, checked for extensions and flags there, closed all Brave session and just launched this profile, however I still had the same issue, even on the new profile.
They work in normal Google Chrome and also in desktop applications like VLC. They also get picked up by websites like https://keycode.info/

Brave Version:
Brave: 1.36.122 | Chromium: 99.0.4844.88

Hi

For my laptop I have to push the function button, fn, for the buttons to work. I tried it on Youtube and on VLC.

For my old HP, it works in a diffrent way. You may need to look it in the manual of your device.

Media keys work out of the box in Brave, no brave://flags changes or anything. If you’re using any drivers (Razer, Cosair etc) check the keys are showing as registered and not disabled (or try disabling said software)

I have dedicated media keys (my keyboard is the Corsair K55), so not this issue

They work and get detected by websites like https://keycode.info/ (forgot to specify before), it’s another issue with how brave handles them

Just tested keycode.info. It worked once I closed Tidal (windows app, since it was stealing the keys), do you have an application open that is monitoring the media keys?

Or maybe other browsers are stealing the key focus?

I have no other browsers open, they also don’t work directly after after me turning on my PC with nothing running in the background and since they still work in something like Chrome I rather think that this is an issue from Brave

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.