Media Keys Not Working

Media keys on my Corsair K70 do not work while Brave is open. It doesn’t have to be the active window to stop them from working. As soon as I close Brave, they operate as normal again. I have already toggled the flag for Brave to control media keys to no avail.

Windows 10. Brave Version 1.20.110 Chromium: 88.0.4324.192 (Official Build) (64-bit)

Thanks for reaching out to us.
In Brave, can you please go to brave://flags and search for a flag called Hardware Media Key Handling. Set the value for this flag to Disabled, relaunch the browser and let me know if this resolves your issue.

I literally said I did that in my original post

I read hundreds of threads every day, please be patient with me and other support staff as we will certainly make silly mistakes like that at times.

Can you please try creating a new temp. browser profile and testing the behavior using it and see if you get different results? Note that you must ensure you close all other Brave windows open at that time (so the window w/new profile is the only one open) before testing. You will likely also have set that same flag to Disabled in the new profile as well.

Created the test profile. If I close all windows and open a new browser window under that profile, the keys work. If I then switch to the other profile (opens a new window with previous tabs) the keys stop working. If I close the non-test profile windows, keys still don’t work. I have to close Brave entirely, then open again with the test profile to get them to work again.

Hmm, that’s strange behavior indeed. My thought was that you were running some extension in your main profile that may have been causing the conflict – something that won’t release control of the media keys. Do you have any extensions installed at this time?

Edit: Actually, I should also ask you to test what the behavior is if you open your new profile window (keys should work), then close it, then re-open it again (the new profile) – do the keys stop working in this scenario as well?

Well it looks like there was an old extension that I wasn’t using any longer, but had been copied over from Chrome and turned on. Didn’t even realize it was still installed, as I hadn’t used it in years heh. Turned it off and that fixed it. This has been fixed. Thanks.

1 Like

Yep, you’re very welcome. Appreciate your support and patience.
Don’t hesitate to reach out should you have any additional questions or concerns.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.