Manage Your Content & Devices page doesn't render

android
#1

Hi,

I don’t know if this is the right way to go about reporting an issue with a specific web page, so please let me know if I’m supposed to do something else.

I just started using this browser today, and so far I’m very impressed. But, the My Content and Devices page of the Amazon.com web site doesn’t render fully and I can’t do anything on that page. For example, I wanted to search by an author’s last name to find all of the books I own by that person so I could delete individual titles that make up the omnibus I just got. I couldn’t enter any character in the search field. I couldn’t expose any choice lists, let alone select an option. Clicking any check box had no affect.

To open the page:

  1. Go to Amazon.com.
  2. On the menu to the left of the logo in the upper-left area of the page, select Kindle E-Readers & Books.
  3. Scroll down to and click Manage Your Content and Devices.

The load line under the address bar moves fairly quickly, the first time you come to the page, but there’s the arrow circling clockwise under the address bar and above the Content tab. And it circles indefinitely. I don’t experience the behavior when I open the page the same way (or using my bookmark) in Firefox or Chrome. I’m doing all of this on a Samsung Galaxy Tab S4.

I love this browser and want to always use it, so I’m hoping to get the rendering issue fixed. If I need to report this some other way, please let me know.

Thanks!

#2

@Lynn,
Thanks for reaching out!
This is likely due to Shield’s Device Recognition setting which defaults to Block 3rd party Device Recognition. To resolve this, try the following:

  1. Visit Amazon.com
  2. Click the Shields icon in the address bar to reveal the Shields panel.
  3. Change the Device Recognition setting to Allow all
  4. Let the page refresh itself

Now try repeating the steps you described and see if the page renders as intended.

#3

I tried that and I still get the same behavior :frowning:

#4

@Lynn,
Thats my bad – I missed that you were using a tablet/Android device and assumed desktop.
Would you mind sharing a screenshot or short recording of the behavior when you go to Content and Devices?

#5

Thanks for the quick reply. I was actually planning on installing Brave on my Asus laptop too, and both of my sons’ Lenovo Yoga laptops, although I use my laptop less and less. So, if I get some time today, I’ll do that and give you more comparision, as well as video what I do on the Tab S4. If I don’t get it done today, it’ll be tomorrow. Gotta do the work thing so I can afford my toys :smiley:

Thanks so much for such quick responses!!!

1 Like
#6

@Lynn,
You’re very welcome, hope to hear back from you soon :slight_smile:

#7

Hey…So, I set Brave up on my laptop, and Cloudflare 1.1.1.1, because those were the 2 changes I made to my Samsung Galaxy Tab S4 10.5 (WiFi only) device too. I can open the Manage Your Content and Devices page off of Amazon from the PC, in the Brave browser with no problem. So, now I’m lost as to what’s going on with the tablet to make it not work

1 Like
#8

@Lynn,
Testing on my Samsung galaxy s9+ , I’m able to visit Amazon and view the Manage your content and devices page without issue – this problem may be specific to tablets (has happened before).
Can you tell me what Brave version you have on your tablet?
Menu --> Settings --> About Brave
Additionally, can you try disabling Shields entirely and seeing if that allows the page to render?

#9

Brave version is 1.0.92. You had me turn off the shield at Amazon.com, before I even navigated to the page. BTW, I didn’t have to turn the shield off on my PC.

1 Like
#10

@Lynn,
I had you disable Device Recognition setting in Shields, but not Shields as a whole (main toggle, top right). Try with Shields down entirely and see if it makes any difference.

I’ve reached out to some Android team members for further input – will be back when I have more info. Appreciate your patience.

#11

My bad. I don’t think I did the device part. I disabled the shield for Amazon entirely.

#12

I just checked the Shield panel and I don’t have a Device Recognition parameter. That’s why I wound up disabling the shield entirely.