Manage Your Content & Devices page doesn't render


I don’t know if this is the right way to go about reporting an issue with a specific web page, so please let me know if I’m supposed to do something else.

I just started using this browser today, and so far I’m very impressed. But, the My Content and Devices page of the web site doesn’t render fully and I can’t do anything on that page. For example, I wanted to search by an author’s last name to find all of the books I own by that person so I could delete individual titles that make up the omnibus I just got. I couldn’t enter any character in the search field. I couldn’t expose any choice lists, let alone select an option. Clicking any check box had no affect.

To open the page:

  1. Go to
  2. On the menu to the left of the logo in the upper-left area of the page, select Kindle E-Readers & Books.
  3. Scroll down to and click Manage Your Content and Devices.

The load line under the address bar moves fairly quickly, the first time you come to the page, but there’s the arrow circling clockwise under the address bar and above the Content tab. And it circles indefinitely. I don’t experience the behavior when I open the page the same way (or using my bookmark) in Firefox or Chrome. I’m doing all of this on a Samsung Galaxy Tab S4.

I love this browser and want to always use it, so I’m hoping to get the rendering issue fixed. If I need to report this some other way, please let me know.


Thanks for reaching out!
This is likely due to Shield’s Device Recognition setting which defaults to Block 3rd party Device Recognition. To resolve this, try the following:

  1. Visit
  2. Click the Shields icon in the address bar to reveal the Shields panel.
  3. Change the Device Recognition setting to Allow all
  4. Let the page refresh itself

Now try repeating the steps you described and see if the page renders as intended.

I tried that and I still get the same behavior :frowning:

Thats my bad – I missed that you were using a tablet/Android device and assumed desktop.
Would you mind sharing a screenshot or short recording of the behavior when you go to Content and Devices?

Thanks for the quick reply. I was actually planning on installing Brave on my Asus laptop too, and both of my sons’ Lenovo Yoga laptops, although I use my laptop less and less. So, if I get some time today, I’ll do that and give you more comparision, as well as video what I do on the Tab S4. If I don’t get it done today, it’ll be tomorrow. Gotta do the work thing so I can afford my toys :smiley:

Thanks so much for such quick responses!!!

1 Like

You’re very welcome, hope to hear back from you soon :slight_smile:

Hey…So, I set Brave up on my laptop, and Cloudflare, because those were the 2 changes I made to my Samsung Galaxy Tab S4 10.5 (WiFi only) device too. I can open the Manage Your Content and Devices page off of Amazon from the PC, in the Brave browser with no problem. So, now I’m lost as to what’s going on with the tablet to make it not work

1 Like

Testing on my Samsung galaxy s9+ , I’m able to visit Amazon and view the Manage your content and devices page without issue – this problem may be specific to tablets (has happened before).
Can you tell me what Brave version you have on your tablet?
Menu --> Settings --> About Brave
Additionally, can you try disabling Shields entirely and seeing if that allows the page to render?

Brave version is 1.0.92. You had me turn off the shield at, before I even navigated to the page. BTW, I didn’t have to turn the shield off on my PC.

1 Like

I had you disable Device Recognition setting in Shields, but not Shields as a whole (main toggle, top right). Try with Shields down entirely and see if it makes any difference.

I’ve reached out to some Android team members for further input – will be back when I have more info. Appreciate your patience.

My bad. I don’t think I did the device part. I disabled the shield for Amazon entirely.

I just checked the Shield panel and I don’t have a Device Recognition parameter. That’s why I wound up disabling the shield entirely.

That’s partially my bad – Device Recognition is also referred to as Fingerprinting Protection. Do you see a Fingerprinting Protection option in Shields on Android?
If so, try disabling it and refreshing the page. If not, this option can be enabled in Settings --> Privacy (for future reference, don’t worry about this now).

I think you should try clearing cache/site data for Amazon and see if this helps.

  1. Visit
  2. Click the “lock” icon in the Address bar --> Site Settings --> Clear & Reset
  3. Refresh the webpage (you may also want to close/relaunch Brave just to be safe)

Now try to view your devices again – any luck?

Sadly, that didn’t change anything.

1 Like

:thinking: :thinking:
Going to ask a few team members who may know whats up, will return with more information. Appreciate your patience!

Actually – may seem strange but can you try launching a Private window, logging into Amazon and seeing if you get the same behavior?

Also, there was an update to v1.0.94 on Android – can you ensure that you’ve updated to the latest release and confirm that the issue is the same?

I just checked Google Play Store, and it shows Brave was updated automatically, yesterday. When I check About Brave, I see 1.0.94

Sorry, I just saw your comment about trying a Private tab. I did test it with the same results–a page that eventually renders completely, but doesn’t let me do anything :frowning:

1 Like

This is very strange. I had some team members respond and confirm that they can view the page without issue so I have a feeling this is isolated but am unsure what to try next.

You might want to try clearing cache for the app itself. Note that there is a difference between the OS system options to Clear cache and Clear all data.
It may vary slightly by OS, but
Clear Cache can be found in [Android device] Settings --> Apps --> Brave --> Storage --> Clear cache

If you don’t have anything particularly important saved in Brave on your device (bookmarks, login data, etc), you can try Clear all data as well – but this will actually remove all Brave data – including bookmarks, cookies, site settings, etc.

If you do want to try that, follow the same path as above, but instead of Clear Cache select Manage storage – this screen should have the Clear all data option available.