Can't log into Amazon

android

#1

Amazon keeps asking me to log in, which it shouldn’t because I always stay logged in. When I try to log in I get no error message but the screen goes back to login. I have turned shields off but that doesn’t help.

Amazon support had me reset password, which looked like it worked but didn’t last long. This problem has been coming up since yesterday (2/2). Yes, Amazon may have changed something to make this happen, but they aren’t going to fix it so Brave must. Works fine with Chrome. Brave 1.0.72, Android 7.0

Similar to this thread but not the same and not solved:


Amazon not allowing 2 factor login from Brave mobile browser
#2

I have the same problem from Friday 1.02 ! Any other mobile browser works.


#3

Could you try clearing up browser cache and retry once again? You did mention that you disabled shields but doesn’t fix the issue so it might be using a cached version of the page. Ensure when you clear data you select time range as All time and have cookies/history/cached images and files selected. You can enable other options as well but do remember depending on what you select certain things might be lost like passwords or site specific settings


#4

Not working. The only workaround so far is to block JavaScript for Amazon website


#5

cc: @joel @michal for more info


#6

This has become a showstopper. I cannot get my Kindle Reader app logged into my Amazon account. If this is not fixed in a day or two, I will have to stop using Brave. I realize this is not Brave’s fault, but I must be able to access Amazon and my books.

I had to enable Java Script just to post this.

ETA: The reason I cannot get my Kindle Reader app logged into my Amazon account is not due to a bug in Brave. It’s due to the fact that Amazon had me change my password to try to fix the problem, which it didn’t. And the Amazon Kindle app on Android doesn’t have a logout/login feature. I would have to de-register my Kindle and then re-register it and then reload all my unread books. Again, none of that is Brave’s problem. But I need to turn JavaScript back on and if I do that right now. I can’t use Amazon at all.


#7

Nothing has changed with the new update


#8

Please track the issue here

Closing the thread for now


closed #9