Major issue with hardware acceleration

hardware acceleration is NEEDED by google maps. if turned off, it went autmatically into “Lite” mode, and we cant tilt and pan anymore, cause there is no “globe” mode -.-
The “Force” Link wont work either Force Web GL

Youtube clip e.g. in 1440p on my 2nd Monitor with 3440x1440@100Hz is only viewable with disabled hardware acceleration example: 1440p clip

with disabled hardware acceleration, it runs smoothly.
with enabled hardware acceleration, the video and audio stutters as hell, and is not viewable…

Brave: Version 1.57.47 Chromium: 116.0.5845.96 (Official Build) (64-Bit)

Asus FA17 Notebook

Win11 x64 Pro 22H2
Ryzen R7 6800H
RTX3070 @1920x1080@144Hz internal and 3440x1440@100Hz external
32GB DDR5-4800
M.2 2x1TB

so what to do?
maybe implement a filter list to chose on which pages hardware acceleration is enabled and disabled…

dunno, or does someone know a workaround, other than turning on / off manually by myself?


cheers ^^


@mareisen issues should be due to your graphics card. You may need to go look through your graphics settings and see if anything is limited. For example, people have found that enabling “Background Application Max Frame Rate” will have impacts on performance within Brave.

You may also want to look through some of the things people have shared at

One of the key things is the last comment:

But just so anyone new who finds this thread knows. This is caused by Background Application Max Framerate on NVIDIA. Changethe option in program settings to off and restart brave to fix it.

Wish I found your post about this, would’ve saved me my troubleshooting adventures. This issue has existed for almost a year now apparently.

NVIDIA appears to set exceptions for chrome.exe, msedge.exe, and firefox.exe. They didn’t add smaller browsers (Brave and Vivaldi) to this exceptions list.

thanks for fast response. it had worked only in browser windowed mode.
when setting to full screen, youtube automatically dropped down from 1440 → 1080 → 720p…
so i did an full uninstall of both gfx drivers, local cpu AMD and RTX3070 Nivia Drivers with newest Display Driver Uninstaller. cleaned and rebooted both uninstalls twice. Then installed only the newest Nividia Driver, didnt changed anything in the new driver with Nvidia Control Panel or the Profile Inspector, just left it as it was

success :slight_smile:
Thanks alot, cheers ^^

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.