Links in other apps (Slack, Telegram, eM Client) don't open in Brave

Two days ago (the 14th of May 2023), I noticed that clicking links in Slack no longer opened in my default browser (Brave, Version 1.51.114 Chromium: 113.0.5672.92 (Official Build) (64-bit)). I thought it was a Slack thing because a colleague had the same issue with Chrome. Then more colleagues reported the same thing, people using a mix of Chrome and Brave, and then we discovered it’s just links in general. So far we’ve tried clicking links in:

  • eM Clien (email)
  • Slack
  • Telegram
  • WhatsApp

…and links just… don’t open in Brave any more. We’re all on Windows (10 and 11), and the browsers (both Brave and Chrome) are on the latest stable release. We’ve double-checked that Windows has those browsers set as the default browsers, and we’ve all rebooted etc, but the problem persists.

Just us, or is the whole thing broken in some way, and we’re the only ones complaining? I’m honestly surprised I haven’t seen public uproar on Twitter about this as it surely affects more people.

1 Like

I’ve just tried opening an email link from eM Client and it correctly opens the link in Brave (the default browser).

I’m wondering whether this is a Microsoft issue (for example, if they changed something in the patch Tuesday update last week – like trying to push Edge again)?

Did you check what the default application for HTTP/HTTPS links is set to in Windows?

1) Go to [Windows 10 settings app > Apps > Default apps > Choose default applications by protocol].

2) Check HTTP and HTTPS are both set to Brave.

1 Like

Microsoft issue/patch change is a good shout. Which version/patch are you on @PDC ?

Both file types and protocols are set to Brave though (I double checked now):

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.