Laptop & Phone are on sync chain, but no tabs are shared

Description of the issue:

I have a sync chain with my laptop (Linux) and phone (Android). The laptop says my phone hasn’t been active for several days. (That’s clearly wrong.) Tabs on my phone can’t be opened on my laptop.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

I don’t know how to reproduce this. It’s just a state the two systems seem to be in. “Automatically sync app data” is enabled on my phone.

Actual Result (gifs and screenshots are welcome!):

Phone shows:

Laptop shows:

Somehow, it appears my laptop has lost its notion of the status of my phone.

Expected result:

I would have expected my laptop to show my phone to have been active within the last few minutes and for at least a few of its tabs (currently 21) to be available from the History>Other Devices menu.

Reproduces how often:

All the time (or at least as often as I want to view a tab from another device).

Operating System and Brave Version(See the About Brave page in the main menu):

Laptop: Ubuntu 20.04, Version 1.24.84 Chromium: 90.0.4430.93 (Official Build) (64-bit)
Phone: Android 11, 1.24.85 Chromium: 90.0.4430.212 (Official Build) (64-bit)

Additional Information:

Restarting my phone doesn’t change the “last active” date of my phone from my laptop’s perspective. I tried removing my phone from the sync chain. It failed on my laptop. On my phone, it appears to remove itself, but when I scan the QR code offered by my laptop (Add New Device), my phone thinks it’s the only device on the sync chain.

This is still a problem for me. I can’t figure out any way to completely deleted my sync chain and start it from scratch. Will I be forced to completely zap my Brave configuration?