Keyboard shortcuts suddenly broken

Description of the issue:
On macOS, a number of global shortcuts that I was used to were suddenly mapped to unexpected different functions in the latest stable version of Brave specifically.

I should note that I use a Czech QWERTY keyboard layout on my Mac.

To give some examples of strange shortcut changes inside Brave:

  • Cmd + left arrow: previously navigated back, now zooms in
  • Cmd + < (the key above the Tab key on Czech keyboards): used to be my global setting for switching windows in an app, now opens settings
  • Cmd + + (the same key as 1 on Czech keyboards, except without pressing Shift): used to zoom in, now goes to the first tab

For all of these, the new behavior goes against the standard shortcut behavior in other apps.

Every version of Brave prior to 1.56.9 worked just fine for me. (I also upgraded to macOS 13.4.1 at the same time — not sure if that plays a role here, though, as every other macOS app I use works normally.)

**Steps to Reproduce (add as many as necessary): **

  1. On macOS, set the Czech QWERTY keyboard layout as the default.
  2. Open Brave.
  3. Visit any website.
  4. Press “Cmd + left arrow” or “Cmd + +”. (Just examples, there are other faulty shortcuts too — at least “Cmd + <”.)

Actual Result (gifs and screenshots are welcome!):
For “Cmd + left arrow”: Zooms in on the page
For “Cmd + +”: Navigates to the first tab

Expected result:
For “Cmd + left arrow”: Navigates to the previous page
For “Cmd + +”: Zooms in on the page

Reproduces how often:
100% of the time

Operating System and Brave Version(See the About Brave page in the main menu):
Brave 1.56.9
macOS 13.4.1


@mirek have you checked your shortcut settings? In the new version (1.56.9), you can add and edit existing shortcuts. Go to SettingsSystemShortcuts.

Hey @Saoiray

Thanks for the pointer!

I didn’t set anything in there myself (though both the Back and Forward keys are empty and clicking “Reset” just sets one of them to Command + “Unknown Key: 0”, which is strange in and of itself). However, it looks like this is this functionality that is interfering with usage.

Unfortunately, it doesn’t seem like it’s possible to set the original shortcuts that Brave had before this version through there:

The recommended solution to use System Settings for this doesn’t work either — it shows up in the UI, but Brave just completely ignores the system setting and uses the browser shortcut instead:


I was at least able to find a workaround for “Cmd + <”:

Next to “Web app settings”, click “Reset”. This moves the “Cmd + ,” shortcut (which somehow Brave seems to map to “Cmd + <” on a Czech keyboard, even though those are different keys) to “Web app settings”. Since web app settings seem to not do anything in a normal browser set-up, the “Cmd + <” shortcut is freed up to be overriden by the system — so the system-wide shortcut works again!

I haven’t found work-arounds for the others, though.

1 Like

I think the shortcuts may have been changed simply due to us implementing this feature even though it shouldn’t have had any effect. Let me reach out to some devs to see if this was expected for some reason and/or if we can do something about it.

1 Like

Hey, this definitely sounds like it’s being caused by the new Keyboard shortcuts customization. Can you try disabling the feature (it’ll require restarting Brave).

  1. Go to brave://flags/#brave-commands
  2. Set the Brave Commands flag to Disabled
  3. Restart

Hopefully that fixes shortcuts while I work on fixing the feature!

1 Like

I had the same issue with “Cmd + <” and your workaround worked!

For me the other shortcuts worked fine, I only had issues with switching windows.

Thank you for your help!

Wonderful, disabling that flag fixes everything!

Thanks for the tip!

1 Like

I need to note that I misremembered the original shortcut for zooming in: it’s actually Cmd + %, not Cmd + + as stated above. Whoops.

The other two shortcuts that I gave as examples were correct, though. (And those two were the ones I was struggling with.)

Thank you! I had the same issue and setting as you (global setting, switching windows) but on a Swedish QWERTY keybord (Macbook Pro). Using your workaround solved it!

I can confirm that the keyboard shortcuts mapping is broken on a German QWERTZ keyboard. Hitting Cmd-< should be the system-wide switching between app windows, now it triggers the Brave settings page. Annoying. Disabling the feature worked though :+1:

Thank you all for the feedback — we are working on getting this sorted out so everyone can make use of the custom keyboard shortcuts as intended.

Issue open here for those of you who’d like to track it’s progress:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.