Switch between windows changed on 1.56.11

On the latest version, the CMD+~ does not switch between windows anymore (like private and regular). Chrome still has it.

Where did this shortcut go? It was one of the most used daily for me and it’s a complete pain using the browser without it.

1 Like

go to brave://settings/system/shortcuts and check things around there or disable the flag for keyboard customization if you don’t like it or it has conflicts with some MacOS shortcut.

1 Like

The new shortcut is “Show settings” but it’s also still set at CMD+, (which works), so it’s really confusing. I can’t find any shortcut for switching windows.

What do you mean with flag for keyboard customization?

The problem is this worked until this latest version, so something definitely changed on Brave, not MacOS.

1 Like

Brave added keyboard customization in latest update, a key in the browser can override what the OS expects or an old behavior about the Browser, which is not a good behavior but it can happen and maybe that’s the issue.
That’s why I said you have to check it and make sure nothing is conflicting with the Keyboard Customization feature and if not, you have to disable it if it is causing issues until resolved, because apparently nobody with a MacOS uses Nightly to give feedback and find the bugs but then they complain how things don’t work, just like Linux users, so when it hits stable, then nobody intercepted the bugs because nobody cared to really test it.
I reported many bugs on with keyboard customization, but some stuff are specific to each OS, and I only reported from a Windows computer.

So, yes, Brave is the one changing and implementing a feature that didn’t have before and might be affecting MacOS’s system shortcuts.


Did you try to clear the customized shortcut in Brave to see if that solved the issue? since you say it is bound to “show settings”, then maybe that’s what causing the issue?
Did you try to change the shortcut in System Prefs > Keyboard > Shortcuts > Keyboard and see if it works with other combination?

I found that the feature is called Move focus to next window and it is **CMD + ** and not **~**, so that might also have to do with it, at least in this screenshot and most websites I saw, it was with and not ~
This is where I saw it anyway, I am a Windows person.

But anyway, that’s why I said, if it doesn’t work because Brave is overriding something it shouldn’t and it is messing with the system OS behavior, then it is better if you disable it. Unless you will customize Brave keyboard shortcuts, then it is better if you disable it if it is causing issues.
At least for now it can be disabled.

1 Like

dsarif70, I think you’re observing the same that I saw.

I never made a change there and switching windows suddenly was not working anymore instead the brave://settings/ opened.

Opening brave://settings/system/shortcuts, it seems there are actually two relevant settings. Thanks Emi for pointing to the shortcuts URL.

With my german language settings, there are these:

Einstellungen anzeigen (i.e. Show settings) with Command+, assigned.
then there is
Web-App-Einstellungen (i.e. web app settings) with no shortcut assigned but a reset button.

When I click the reset on web app settings, then the shortcut Command+, is assigned to that function, it is removed from show settings and show settings now has the reset function button.

The result is that everything works as expected again.
I can use Command+, to open settings and I can use my macOS-wide-set keyboard shortcut to switch between brave windows.

1 Like

I’ve disabled Brave Commands through brave://flags/#brave-commands and now the expected behavior is back.


1 Like

The solutions given here are not working on Brave v1.61.101 .
The only one is to change my old way of using CMD+tab for switching windows to CMD+~
This one is just above tab key